ConnectX-2 on Ubuntu 18.04

Hello-

I have a number of older servers with ConnectX-2 VPI IB cards running a very old OS (Ubuntu 10.04). We want to take them to Ubuntu 18.04 instead. As I understand it, Mellanox is only providing Ubuntu 18.04 installers for OFED v 4.x, however support for ConnectX-2 cards was dropped in this version of OFED. So it seems I need to get OFED 3.x installed on Ubuntu 18. Has anyone had any success with that, or could please offer some advice? Or is there any hope an official installer could be provided? I see OFED 3 is supported on Ubuntu 16, but it’d be great if we could use the newer OS for 2 years more longevity. Thanks for any advice!

-Lewis

Hello-

In case someday anyone else would like to try, we went ahead and upgraded to Ubuntu 18 and OFED 4, and our old ConnectX-2 IB cards are still working fine with this setup, despite the release notes indicating support was dropped.

-Lewis