Convert custom data to TFRecords error MaskRCNN

Please provide the following information when requesting support.

• Hardware T4
• Network Type Mask_rcnn
• TLT Version Tao 3.2.55
• How to reproduce the issue ? (This is for errors. Please share the command line and the detailed log here.)

Hello professor:
I use the mask RCNN by notebook. I hope train the model with my dataset. So at labeled the image by labelme, and translate them into coco. I hope to use the code"tao mask_rcnn dataset_convert" to translate it into tfrecord.

However I meet the problem:
tensorflow.python.framework.errors_impl.NotFoundError: /workspace/tao-experiments/data/raw-data/train2017/JPEGImages\1.jpg; No such file or directory

my Mounts is

the path of the image is

the error is

Thank you very much.

Can you run below command to check if the image is available?

$ tao mask_rcnn run ls /workspace/tao-experiments/data/raw-data/train2017/JPEGImages/1.jpg

Thank you very much.
I run the code and get

It seems can work.

I find a problem: the error is
“tensorflow.python.framework.errors_impl.NotFoundError: /workspace/tao-experiments/data/raw-data/train2017/JPEGImages\1.jpg; No such file or directory”

here, the “/JPEGImages\1.jpg” is not “/JPEGImages/1.jpg”.

Maybe I solved it.
Because the coco json is produced in Windows, so the path is “\”, I modified it . It seems can work.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.