CoolBits stopped working?

I’ve been using Coolbits setting in xorg.conf for a while now, but now suddenly I do not see the option to change the offsets in nvidia-settings. Was it disabled? Note that manual fan control is still there (bit 2)!

The driver I’m using is: 520.56.06
Xorg: (11.0)

In xorg.conf I have only:

Section "Module"
    Load           "modesetting"

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    BusID          "PCI:f:0:0"
    Option         "AllowEmptyInitialConfiguration"
    Option         "AllowExternalGpus" "True"
    Option         "Coolbits" "12"
0f:00.0 VGA compatible controller: NVIDIA Corporation TU116 [GeForce GTX 1660 SUPER] (rev a1)
$ grep -i cool /var/log/Xorg.0.log 
$ grep -i allow /var/log/Xorg.0.log
[     4.837] (==) Max clients allowed: 256, resource mask: 0x1fffff
[     4.924] (**) NVIDIA(0): Option "AllowEmptyInitialConfiguration"
[     4.924] (**) NVIDIA(0): Option "AllowExternalGpus" "True"

I don’t know if CoolBits was removed but your xorg.conf is broken.
BusID wants decimal values, so it’s “PCI:15:0:0” and the Load "modesetting" directive shouldn’t be used anymore, breaks with nvidia drm modesetting.
Rather use a conditional snippet instead, /etc/X11/xorg.conf.d/nvidia-options.conf

Section "OutputClass"
    Identifier "nvidia-options"
    MatchDriver "nvidia-drm"
    Driver "nvidia"
<put your options here>

Edit: sorry, wrong value, changed.

1 Like

Thanks for directing me in the right direction!

The problem was caused after update of egpu-switcher. I’ve updated it and run the configuration and it created the /etc/X11/xorg.conf.d/99-egpu-switcher.conf file that was overwriting my xorg.conf.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.