Cooling Fan Not Working

Cooling fan not working after update the new version.

When I run sudo jeton_clocks it show the clock is running but fan is not working to 100% speed.

image

hello wmindramalw,

I assume you’re working with JetPack-4.4/ l4t-r32.4.3
could you please check the fan configurations through hw monitor and share the results.
for example,

*check the sysnodes of hwmon
cat /sys/class/hwmon/hwmon*/name 

*check the current settings and also the measured rpm
cat /sys/class/hwmon/hwmon2/cur_pwm
cat /sys/class/hwmon/hwmon2/rpm_measured

try running

sudo jetson_release

under “jetson_clocks service: <active/inactive>” should tell you if jetson_clocks is working or not.

Mine says inactive, so I can confirm i have this issue as well.

Yes, I have a new update. JetPack-4.4/ l4t-r32.4.3.

Please find the output for your commands.

NOTE: If you want some details to improve the new issue update with my device, I am happy to give details about what you want.

hello wmindramalw,

I’m able to force fan spinning with below commands, could you please also have confirmation.
for example,

echo 255 > /sys/class/hwmon/hwmon2/target_pwm

This is outputs for echo 255 > /sys/class/hwmon/hwmon2/target_pwm

This is output for echo 255 > /sys/class/hwmon/hwmon2/target_pwmfan and sudo sh -c ‘echo 255 > /sys/devices/pwm-fan/target_pwm’.

Fan is working 100% for sudo sh -c ‘echo 255 > /sys/devices/pwm-fan/target_pwm’ command.

This is without running jetson_clocks.

hello wmindramalw,

there’s modification in JetPack-4.4 that fan speed will be controlled based on the temperature,
please enable the options if you would like to enable jetson_clocks also set fan speed to maximum as old behavior.
for example, $ jetson_clocks --fan

you may also check Fan Mode Configuration for more details.
thanks

1 Like

jetson_clocks --fan command is work for me. Thank You.

44

1 Like