Correct install/setup process for nvidia cuda oceanfft sample w opengl & cufft centos 7

Running centos 7 w gtx 980m device w nvidia 355.11 driver
Installed cuda toolkit 7.5
Whe i try to build oceanfft cuda-opengl-cufft sample getting link error ld cannot find
Non-GL samples build and run fine

Also curiously the glxinfo tool runs fine
and if I do ldd /usr/bin/glxinfo it shows

Tried installing freeglut3, latest glew tarball (get same error when I try to build that),
Also Mesa GL and Glu development libraries, but still not fixed.

Want to start over and make sure Im getting all required packages/dependencies in correct order.
What is the right way? Cant find complete instructions in nvidia toolkitThx.

Well this post fixed my error: the symlink was dangling, repointed to which points to

However, pretty sure I installed a bunch of stuff I don’t really need while trying to fix this.
So I’d still appreciate a clear explaniation of what the recommended minimum development setup configuration is to support CUDA with OpenGL integration.

(i.e. is installing freeglut3 and/or glew-1-13.0 redundant? what about the mesa GL devel libraries?)

New to Linux and CUDA/OpenGL development, so everything is confusing. Thanks.