Correct setup to use Trace32 and Correct mount/unmount parts on carrier board.

Now I’d like to use JTAG by “Lauterbach Trace32” to debugging of Jetson TX2 on carrier board.
But now I couldn’t connect them.
Could you please give me any advice?
I’d like to know correct setup to use Trace32, and correct parts mounting on carrier board.

-Setup of Trace32
I attached a print screen.
The debugger is “LA-7708 DEBUG-USB2”.

-Parts on carrier board
Mount R52 (to PU the JTAG_AP_TRST_L)
Mount R150 (to PD the Q22-G, to PU the NVJTAG_SEL and +1.63V is observed at Q22-D)
A jumper pin on J8 (to connectRESET_OUT_L to GND.)
I read Jetson TX2 Boundary Scan Application Note, but if there is anything lacked, please teach me it.
pict_Trace32-0.PNG

pict_Trace32-0.PNG

Get the 24.2.1 l4t document to check “Lauterbach Debugging Scripts” chapter.
And get the lauterbach for TX2 from https://developer.nvidia.com/embedded/dlc/l4t-lauterback-28-2-ga

Thanks for introduce the document.
I tried to download and unzip(untar?) it.

But I couldn’t open correctly.
My unzip tool failed to open it.

I tried following tools

  • lhaplus
  • Universal Extractor (this tool following tbz2 extension)

Can Linux open this file? I tried them only on Windows machine.

This is standard on Linux. Compression is from bzip2 (and decompression bunzip2). Combined with a “.tar” archive file format, this is a “.tar.bz2” file…abbreviated as “.tbz2”.

Two ways:

bunzip2 < lauterbach_R28.2.0_aarch64.tbz2 | tar xv
# OR:
tar xvfj lauterbach_R28.2.0_aarch64.tbz2

…either way first unzips, then extracts. You’ll get a “lauterbach/” subdirectory at the point of unpack.

Thanks for reply.
But I couldn’t reached good result.

I tried following command on Jetson TX2. But the terminal outputs no message.[

$ bunzip2 < lauterbach_R28.2.0_aarch64.tbz2 | tar xv

And I tried same command with no “<”.
The file is converted to just a .tar file, but tar command returns following message.

“This does not look like a tar archive”

I re-downloaded same file 3 times and I got same result for all of them.
Ofcourse I tried your second suggestion to use “tar xvfj” but the terminal shows no return.
Do you have any ideas?

Looks like the file is empty.
Please wait for new upload.

Thanks for reply.
Can I ask you about when is the new script released?
And if new one is released, then notification or something would be described in here?

It may take time due to internal IP audit process for releasing package.
The system will send you mail if you follow this topic once have any new update from the thread.

Thanks a lot for your kindly support.
I wait the update.

reagards,

Hello, so I could success to download Lauterbach script file.
And I unpacked the tbz2 file.

But… I can’t identify which file contains the “Lauterbach Debugging Scripts chapter”.
I downloaded “L4T Documentation 24.2.1”. And I used serch to find “Lauterbach” but I couldn’t.
I’m so sorry to make you busy but could you please introduce and indicate me which is the one what I should download? (or give me the link?)

regards,

Should be like this. But the script you download only for TX1 now. You can try it on TX1 first. We need time for the TX2.