Correct version of tensorflow for Jetpack 4.4

Hi All,
I was looking at the Donkey Car docs for installing Donkey Car on the Jetson Nano. The docs say to install the present Jetpack which is now 4.4 and should require tensorflow from https://developer.download.nvidia.com/compute/redist/jp/v44 and not https://developer.download.nvidia.com/compute/redist/jp/v42 as the Donkey Car docs say to install?
Comments?
Regards, TCIII

Hi,

YES. Please install the Tensorflow built for the same JetPack version.
For JetPack 4.4 product release, it’s recommended to use following package:
v2.2.0
https://developer.download.nvidia.com/compute/redist/jp/v44/tensorflow/tensorflow-2.2.0+nv20.7-cp36-cp36m-linux_aarch64.whl
v1.15.3
https://developer.download.nvidia.com/compute/redist/jp/v44/tensorflow/tensorflow-1.15.3+nv20.7-cp36-cp36m-linux_aarch64.whl

Thanks.

@AastaLLL,

Thanks for the input, much appreciated.

I wound up using the following: “pip3 install --no-cache-dir --pre --extra-index-url https://developer.download.nvidia.com/compute/redist/jp/v44 ‘tensorflow<2’” which appears to be running fine on my Jetpack 4.4 install on a Nano. I assume that this probably installed Tensorflow 1.15 or higher but <2?

Regard,
TCIII

I use python3.7.9 ; Jetpack4.4 ,cuda10.2 .
which tensorflow version to install ? jetson nano.
at same nano,Python3.6 install tensorflow ok.
I use virtualenv ,python3.7.9 will install tensorflow.

fyi, TensorRT 7.1.3 has been tested with TensorFlow 1.15.2, so some apps work and some don’t with 2.x.

https://docs.nvidia.com/deeplearning/tensorrt/release-notes/tensorrt-7.html#rel_7-1-3

Hi, TCIII

We support both v1.15.1 and v2.2.0 for the JetPack 4.4 software.
Since v1.15 and v2.2 API has lots of different, please check the Donkey Car project for which one to use first.

Thanks.

Hi, xaseven

We don’t support python3.7.
Our package is built for python 3.6, the default python version used in Ubuntu18.04.

Thanks.

Ok,Thanks

@AastaLLL,

Thanks for the response, much appreciated.
I am presently running Jetpack 4.4 on my Donkey Car Nano including Python 3.6.9, CV2 4.1.1, and Tensorflow 1.15.3.

The Tensorflow was obtained from here: ```
pip3 install --no-cache-dir --pre --extra-index-url https://developer.download.nvidia.com/compute/redist/jp/v44 ‘tensorflow<2’

Will that be a problem since you are recommending Tensorflow v1.15.1?
Presently Donkey Car software does not support Tensorflow v2 and up.

Regards,
TCIII

Hi,

No. TensorFlow v1.15.3 should be fine.

Thanks.