Corrupted Bootloader on Jetson Nano

Hello everyone,

I’m encountering a critical issue with my Jetson Nano where the boot loader seems to be corrupted. Unfortunately, I’m unable to boot the device, and I’m seeking urgent assistance to resolve this issue.

Problem Description:
Upon attempting to power on the Jetson Nano, it fails to boot properly. Instead, I receive an error message indicating a corrupted boot loader. I’ve tried restarting multiple times, but the issue persists.

Steps Taken:

I've attempted to re-flash the boot loader  but it doesn't seem to resolve the problem.
I've checked all connections and peripherals to ensure there are no physical issues causing the problem.
I've also tried booting from a different SD card with a fresh installation, but the boot loader error persists.

Additional Information:

Jetson Nano Model: 945-13450-0000-100 | Jetson Nano Developer Kit
host OS:Ubuntu 18.04 

Request for Assistance:
I’m reaching out to the community for any guidance or suggestions on how to troubleshoot and resolve this boot loader
L4T TegraBoot.txt (3.2 KB)
issue. I would greatly appreciate your assistance. i attached the error log FYR

Best regards,
Hari Prasath

I am more curious about what is your method to “reflash” bootloader?

Most of cases here are you actually didn’t flash or didn’t succeed in flashing the bootloader.

thank you for your replay

i am not re flash the boot loader just i try to reflash the nano through sdk manager.
(i am wrongly mention above " I’ve attempted to re-flash the boot loader but it doesn’t seem to resolve the problem.") so not consider this case

Best regards,
Hari Prasath

Ok, what happened when you flash nano through sdkmanager? It feels like the flash didn’t succeed.

image flashing completed successfully , after image flashing i am try to get the nano display via hdmi port even if i not seen nano home screen and i am do all possible solutions like i change the monitor and hdmi cable but the nano not get boot up . while this time i get the boot log from nano the boot log attached from previous message please find it .

additional information
host : Linux 18.04
sdk manager version : 2.0.0
jet-pack os version (i am try to install) : 4.6.2

please share the full flash log from host and device side to let us make sure it is really successful.

Your previous log only shows the flash seems not successful.

Hi
please find the attached flash log in bellow

SDKM_logs_JetPack_4.6.2_Linux_for_Jetson_Nano_modules_2024-02-28_18-08-27.zip (404.2 KB)

  1. Could you flash the latest rel-32.7.4 version instead of 32.7.2?

  2. When you flash the board, could you also dump the uart console in the background?

The project in production mode , so i could not change the jet pack release version 4.6.2 with L4T 32.7.4(latest release ) so please suggest the any open point to resolve the issue

This is debug purpose only. Please just follow what I said and do the flash.

I am not asking you to use this version forever.

ok,i will do and get back to you shortly

Is this still an issue to support? Any result can be shared?

There is no update from you for a period, assuming this is not an issue any more.
Hence we are closing this topic. If need further support, please open a new one.
Thanks