Corrupted images with 4K camera connected in USB2

Dear all,

I tried to use the CU130, a 4K camera from e-con, connected to a TX1 via the usb2 connector of the J120 carrier board without succeed.

My issue is the images are compressed in jpg and can have varied sizes depending of what the camera see. This changing usb2 bandwith is readable under windows but leads to issue with linux whatever the hardware (TX1, core i7).

In the pipe between uvc and decoder, the images are not red completely sometimes. If the buffer is splitted in the middle of image, the decoding algorithm works. But if the buffer is splitted in the header, the decoder stops and the recording pipe too.

I used jpecdec, nvjpegdec with gstreamer and gucview too.
Gucview use a parser to delete the header corrupted image, but you can see the others.

I have two question:

  • why does it works with windows and not with linux, uvc is not common ?
  • Have you any idea to avoid to split buffer ?

Thanks,

Hi,
We have verified CU135
https://devtalk.nvidia.com/default/topic/1029050/jetson-tx1/usb-host-controller-dies-when-attempting-to-receive-frames-from-usb3-camera/post/5235049/#5235049

Can you try to connect to default developer kit instead of J210?

Dear Dane,

Thanks for your answer.
As i said, it looks like independant of hardware (TX1, J120, kit dev, Core I7).

To answer to your question, I tried on TX2 devkit with CU130 from e-con.

Hi Chris,

I am a developer from e-con System’s USB camera department. Did you try and check if the issue is recreated with e-con’s QtCAM software? You can download it here and its open source - https://www.e-consystems.com/opensource-linux-webcam-software-application.asp

Dear Arun,

Thanks for your interest !

Yes i tested with qtcam which parses images and delete corrupted ones.

The problem is you lost 50% fps compare to windows with same hardware.
In addition the images are not spreaded homogeneously along the time.