Could not get EGL display Connection inside nvidia jetson docker container, Segmentation fault core dumped

I have a My-detections python script it has worked many times before but now I get the error “Could not get EGL display Connection” as well as segmentation fault core dumped.

The weird bit is no changes were made to the file, and some times instead of these errors I get Gstreamer warnings, and some times the script just works.

There seems to be no indicator of what is wrong other than a display problem.

I am inside of the Jetson-inference Docker container

Any idea what this could be about?

I have tried export DISPLAY=:0


Does this issue have a failure rate? Sometimes work but sometimes fails.

Have you tried the detection outside of the container?
Is it working always?


I found the freezing happened because in the scripts I changed network from “host” to “bridge”. I don’t know why this causes that and if there is any way to still be able to keep the network on bridge.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.