Could not run fq2bam

Hi, I tried to run fq2bam, but I got the following error.

[Parabricks Options Mesg]: Checking argument compatibility
[Parabricks Options Mesg]: Automatically generating ID prefix
[Parabricks Options Mesg]: Read group created for /storage1/fs1/jin810/Active/xxx_R1.fastq.gz and
[Parabricks Options Mesg]: @RG\tID:HYN57CCXX.1\tLB:lib1\tPL:ILLUMINA\tSM:CH-F0012-001U\tPU:HYN57CCXX.1
[PB Info 2023-Nov-08 03:35:39] ------------------------------------------------------------------------------
[PB Info 2023-Nov-08 03:35:39] || Parabricks accelerated Genomics Pipeline ||
[PB Info 2023-Nov-08 03:35:39] || Version 4.0.0-1 ||
[PB Info 2023-Nov-08 03:35:39] || GPU-BWA mem, Sorting Phase-I ||
[PB Info 2023-Nov-08 03:35:39] ------------------------------------------------------------------------------
[M::bwa_idx_load_from_disk] read 3171 ALT contigs
For technical support visit Help - NVIDIA Docs

Could not run fq2bam
Exiting pbrun …
Please visit NVIDIA Clara - NVIDIA Docs for detailed documentation

The command that I used:

pbrun fq2bam --x4 --ref “${REF}”
–in-fq “${fastq_r1}” “${fastq_r2}”
–knownSites “${KS1}”
–knownSites “${KS2}”
–knownSites “${KS3}”
–out-bam “${out_path}/${sample_name}_fq2bam_output.bam”
–out-recal-file “${out_recal}”
–out-duplicate-metrics “${out_duplicate_metrics}”
–read-group-pl ILLUMINA
–read-group-sm “${sample_name}”
–tmp-dir “${temp_dir}”
–num-gpus 1

bsub -Is -G compute-jin810 -q general-interactive -n 4 -R ‘gpuhost’ -gpu “num=1:gmem=8G” -a ‘docker(’ /storage1/fs1/jin810/Active/

Could anyone help? Thanks!

Hey @Leo8888,

I would recommend increasing your system requirements if you can. In your bsub command I would suggest two changes:

  1. increasing the GPU num from 1 to 2
  2. if “gmem” stands for GPU memory, then I would increase that from 8G to at least 16G

Thanks for your reply! I got the same error after making the changes that you suggested. Should I increase the number of GPU and memory more?