Couldn' t able to access 4 GMSL(CSI) camera using Deepstream on AGX ORIN

@le.lokaram.t
It looks like a delay is needed between the cameras. If you add 1s delay before running video1, video2 and video3, is the issue still there?

The above workaround worked to some extent. However, I can only do it by adding delay between individual ‘gst-launch-1.0’ pipelines.
Let me know if there’ s any better way to do it.
Thanks.

#!/bin/bash

gst-launch-1.0 nvarguscamerasrc sensor-id=0 ! 'video/x-raw(memory:NVMM), width=(int)2880, height=(int)1860, framerate=30/1' ! \
            nvvidconv flip-method=0 ! 'video/x-raw, format=(string)I420' ! xvimagesink -e & 
sleep 1 
gst-launch-1.0 nvarguscamerasrc sensor-id=1 ! 'video/x-raw(memory:NVMM), width=(int)2880, height=(int)1860, framerate=30/1' ! \
            nvvidconv flip-method=0 ! 'video/x-raw, format=(string)I420' ! xvimagesink -e & 
sleep 1 
gst-launch-1.0  nvarguscamerasrc sensor-id=2 ! 'video/x-raw(memory:NVMM), width=(int)2880, height=(int)1860, framerate=30/1' ! \
            nvvidconv flip-method=0 ! 'video/x-raw, format=(string)I420' ! xvimagesink -e & 
sleep 1 
gst-launch-1.0 nvarguscamerasrc sensor-id=3 ! 'video/x-raw(memory:NVMM), width=(int)2880, height=(int)1860, framerate=30/1' ! \
            nvvidconv flip-method=0 ! 'video/x-raw, format=(string)I420' ! xvimagesink -e &

Hi,
Please apply this lib for a try:
Argus pipeline randomly gets error - #10 by JerryChang

Information about the prebuilt lib:
DeepStream 6.2 Upgrade Issues on Jetson Xavier NX: Argus Camera Socket Errors - #13 by JerryChang

Thanks DaneLLL, I’ ll give it a try.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.