couldn't get an RGB, Double-buffered, Stereo visual

I wanna shoot the 3D stereo in ubuntu, but I cannot shoot the 3D-stereo. When I run the command “glxgears -stereo”, it showed “Error: couldn’t get an RGB, Double-buffered, Stereo visual”

I edited the Xorg.conf like these:

nvidia-settings: X configuration file generated by nvidia-settings

nvidia-settings: version 418.56

nvidia-xconfig: X configuration file generated by nvidia-xconfig

nvidia-xconfig: version 418.56

Section “ServerLayout”
Identifier “Layout0”
Screen 0 “Screen0” 0 0
InputDevice “Keyboard0” “CoreKeyboard”
InputDevice “Mouse0” “CorePointer”
Option “Xinerama” “0”
EndSection

Section “Files”
EndSection

Section “Module”
Load “dbe”
Load “extmod”
Load “type1”
Load “freetype”
Load “glx”
EndSection

Section “InputDevice”

# generated from default
Identifier     "Mouse0"
Driver         "mouse"
Option         "Protocol" "auto"
Option         "Device" "/dev/psaux"
Option         "Emulate3Buttons" "no"
Option         "ZAxisMapping" "4 5"

EndSection

Section “InputDevice”

# generated from default
Identifier     "Keyboard0"
Driver         "kbd"

EndSection

Section “Monitor”
Identifier “Monitor0”
VendorName “Unknown”
ModelName “Dell S2417DG”
HorizSync 34.0 - 232.0
VertRefresh 30.0 - 150.0
Option “DPMS”
EndSection

Section “Device”
Identifier “Device0”
Driver “nvidia”
VendorName “NVIDIA Corporation”
BoardName “Quadro P5000”
EndSection

Section “Screen”

Removed Option “Stereo” “10”

Identifier     "Screen0"
Device         "Device0"
Monitor        "Monitor0"
DefaultDepth    24
Option         "TwinView" "0"
Option         "AllowDFPStereo" "yes"
Option         "UBB" "True"
Option         "Stereo" "10"
Option         "nvidiaXineramaInfoOrder" "DFP-1"
Option         "metamodes" "2560x1440_120 +0+0"
Option         "SLI" "Off"
Option         "MultiGPU" "Off"
Option         "BaseMosaic" "off"
SubSection     "Display"
    Depth       24
EndSubSection

EndSection

nvidia-bug-report.log.gz (1.16 MB)

nvidia-bug-report.log.gz (1.1 MB)

Please run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.
https://devtalk.nvidia.com/default/topic/1043347/announcements/attaching-files-to-forum-topics-posts/

I have upload the log , could you find it?

You used the .run installer with --no-opengl-files option. Either re-run it without that option or better:

Many thanks for your kindly help. I have successfully installed ubuntu graphics driver according to your guidance, and I also could run glxgears-stereo hopefully. But I couldn’t see a double image. I also could not see the image in stereo even when I put on 3D Glasses. The light of emitter was in green ,but it could not turn greener when I run glxgears-stereo. I’ve set it up successfully before and I have seen the light of IR transmitter more bright.

Could you mind giving me another help?

Thanks advance!
nvidia-bug-report.log.gz (1.1 MB)

My desktop manager is mate