CPU Bootloader is not running on device

Hi, I’m using leopard imaging LI-XNX-6CAM carrier with the Xavier NX and it works fine with all the standard flashing and installations, but when I try to flash the devkit OSM with their instruction, and their dtb file it fails.
the production OSM works with this dtb file, and the camera driver works as well. it’s just the devkit OSM that cant be flashed with this dtb. I also tried to build the dtb with their patches but it didn’t solve the problem.

this is a log from the flashing of the devkit OSM:log.txt (41.2 KB)

when executing the flash command it stuck where the log ends. i tried to leave it for a few hours but it just prints it again and write “CPU Bootloader is not running on device” just like in this topic

This is the instructions for the carrier: IMX477-MIPI_R32.4.3_NX_CB6_20200921_Driver_Guide (2).pdf (925.2 KB)

please tell me if you recognize anything wrong, or if this procedure works for you.

@WayneWWW
thanks!

Hi,

Do you mean when you try to flash NVIDIA devkit with their dtb, it will get fail?
Could you try to dump the device side log from uart during flash?

when i try to flash nvidia devkit with the dtb provided by leopard imaging for their carrier it happeneds

Ok then could you dump the log from uart ?

uart.log (11.3 KB)

Ok, then I can only say please do not use their dtb on devkit.

Looks like they remove some gpio expander related stuff in dtb and this will cause flash failure.

1 Like

Any reason that you have to use their dtb on our devkit?

Yes. its a carrier with 6 mipi camera outputs and the dtb allows me to use those ports. i cant use the production module because of the low storage memory. they advertize their product for the devkit module and offer support. when i told them about the issue they said its “weird” and its the first time they encountered this problem.
i have their patches files, is it possible to compile the dtb in a way that will work with the devkit module?

You can try to use their patch and apply to original dts provided by jetpack. Try to keep things instead of disabling and see if it can flash or not.

Hi,

I just notice it is “devkit module” so it is with sdcard slot on it?

Hi lidor,shim,
Sorry for the trouble. Please try this dtb file. The Image file is not changed.