CPU Isolation Issue on Nvidia Jetson Orin Developer Kit 64GB

I’m currently using the Nvidia Jetson Orin Developer Kit and encountered an issue regarding CPU isolation.

In my previous work with the Jetson Orin 32GB kit, I modified the /boot/extlinux/extlinux.conf file as follows to isolate all CPU cores except for the first one (index 0):

APPEND ${cbootargs} root=/dev/mmcblk0p1 rw rootwait rootfstype=ext4 mminit_loglevel=4 console=ttyTCU0,115200 console=ttyAMA0,115200 console=tty0 firmware_class.path=/etc/firmware fbcon=map:0 net.ifnames=0 nv-auto-config isolcpus=1-11

This configuration worked without any issues on the Jetson Orin 32GB kit.
However, when I tried the same setup with the Jetson Orin 64GB kit, the device failed to boot.
It only successfully boots and operates normally if I leave two cores (index 0 and 1) unisolated.

My question is, does the Nvidia Jetson Orin 64GB kit require a minimum of two CPU cores to operate correctly?
Any insights or suggestions would be greatly appreciated.Thank you.

1 Like

As updated at Flash Failure on Jetson Orin 64GB Dev Kit using Jetpack 5.0.2 - Jetson & Embedded Systems / Jetson AGX Orin - NVIDIA Developer Forums, ae you using JetPack 5.0.2 for Orin 64GB kit?
Please use the JetPack 5.1.1 to se if issue still presented. Thanks

Oh, first of all, thank you for the answer.

This question and that question were separate questions.

This issue occurs in the Jetson Orin 64GB kit and JetPack 5.1.1.
I wonder if the Jetson Orin 64GB kit requires 2 CPU cores to boot the OS.

Additionally, this issue did not occur with the Jetson Orin 32GB kit and Jetpack 5.0.2.

By default we don’t set isolcpus, so it is possible it does not work properly in certain condition. For using Orin 64GB, is it good for you to have core 0 and 1 unisolated? If this configuration works, we would suggest use it.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.