Crash regularly occuring when using GPU for object detection

Hello,
I have no idea why it doesn’t work properly, but my Jetson Nano is unable to handle object detection when using the GPU. I use the DNN module of OpenCV to run a MobileNetSSD-v2 model. Everything on the software side is fine, I build OpenCV with Cuda support and sometimes, the detection works for like 5 seconds or so. However each time, either at the beginning or a few seconds in, my Jetson Nano crashes and just turns off.

  • I get no error message.
  • I check with $ jtop and it doesn’t seem like a memory shortage is the case.
  • I use 5V-4A DC power supply.
  • No, for me, switching to 5W mode is not an option. I need fast framerates and to use all 4 CPU-Threads for multithreading purposes simultaneously.

I really need to get this system up and running, so is there any suggestion how to solve the problem? Thanks!

When it “crashes,” what is the kernel debug log?
Can you turn on serial console debugging, and see if you get some kind of oops or panic out?

Hi,

Although it is not an option, would you mind running the application with 5W mode first?
This experiment will help us clarify the cause is from memory or power starvation.

Thanks.

Hi, thanks for your suggestion. Would you mind giving a short explanation on how to do that and what I have to look out for? I’m still relatively new to the system, thanks!

Hi, thank you for answering. I just ran it in 5W mode and can confirm that it runs well.

Hi,

So this issue is caused by power starvation.
Please check this topic for information on the power supply:

Thanks.

Thanks, but as I already said, I use 5V-4A power supply, so besides I already found it by myself, it helps me fairly little. Since I can’t provide even more power to the Nano, do you have specific suggestions on how to solve the issue?

Hi,

So you will need some manual settings for your use case.
If all 4-CPU are enabled but run with a slower clock rate, is this acceptable?

You can find the detailed setting of nvpmodel below:

Maybe you can try some combination like 4 CPU @ 918 MHZ.
The power budge should be roughly between 5watts and 10watts.

Thanks.

Thank you, this solved the issue. I defined an additional power mode to use 4 CPU at 918Mhz.

Good to know this.

Thanks for the feedback!