Crashloopbackoff error when deploying test application k3s

Hello all, I have set up a kubernetes cluster using k3s with rancher. There is one jetson nano master node, and two jetson nano workers. I then tried deploying a test application to make sure it’s working properly, following the steps outlined here: How to Deploy Your Application to Kubernetes (rancher.co.jp) but i keep getting a CrashLoopBackOff error. I’ve tried completely reinstalling k3s, and re-joining the worker nodes, but nothing worked.

When I run kubectl get pods i get this showing my test deployment.

NAME                      READY   STATUS             RESTARTS     AGE
mysite-57b5b46f97-nr4z7   0/1     CrashLoopBackOff   1 (4s ago)   11s

Running kubectl get nodes yields this, showing that I have all my nodes connected.

NAME     STATUS   ROLES                  AGE   VERSION
master   Ready    control-plane,master   26h   v1.23.6+k3s1
node2    Ready    <none>                 26h   v1.23.6+k3s1
node1    Ready    <none>                 26h   v1.23.6+k3s1

I’ve tried killing the deployment and restarting it as well, it always ends with a CrashLoopBackOff error. Can anyone help me with this?

Hi,

Could you share the kubectl logs output with us first?

$ kubectl logs mysite-57b5b46f97-nr4z7 

Thanks.

hello, this is the output of kubectl logs.

standard_init_linux.go:228: exec user process caused: exec format error

Hi,

In general, the error occurs when launching an x64 container/binary on the Jetson, which is an ARM platform.
Could you give it a check?

Thanks.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.