CRC error on MMC1 device on Jetson Nano

I enabled the second mmc1 interface as
mmc1: SDHCI controller on sdhci-tegra.2 [sdhci-tegra.2] using ADMA 64-bit with 64 bit addr
on the Jetson Nano Developer Kit P3448 (16gb eMMC). After the update to JetPack 4.6.3 II am starting to get the following error (below). It appears that only single block read works?

Any help appreciated

[ 11.124925] mmc1: Data CRC error
[ 11.128156] sdhci: =========== REGISTER DUMP (mmc1)===========
[ 11.133980] sdhci: Sys addr: 0x00000020 | Version: 0x00000303
[ 11.139804] sdhci: Blk size: 0x00007200 | Blk cnt: 0x00000006
[ 11.145627] sdhci: Argument: 0x00000800 | Trn mode: 0x0000003b
[ 11.151449] sdhci: Present: 0x01fb0000 | Host ctl: 0x00000013
[ 11.157271] sdhci: Power: 0x00000001 | Blk gap: 0x00000000
[ 11.163092] sdhci: Wake-up: 0x00000000 | Clock: 0x00000007
[ 11.168912] sdhci: Timeout: 0x0000000e | Int stat: 0x00000000
[ 11.174733] sdhci: Int enab: 0x02ff100b | Sig enab: 0x02fc100b
[ 11.180554] sdhci: AC12 err: 0x00000000 | Slot int: 0x00000000
[ 11.186375] sdhci: Caps: 0x376cd08c | Caps_1: 0x10006f77
[ 11.192197] sdhci: Cmd: 0x0000123a | Max curr: 0x00000000
[ 11.198016] sdhci: Host ctl2: 0x00003001
[ 11.201932] sdhci: ADMA Err: 0x00000000 | ADMA Ptr: 0x00000000ffefe410
[ 11.208470] sdhci: ===========================================
[ 11.214551] mmcblk1: error -110 sending stop command, original cmd response 0x900, card status 0x400900
[ 11.214560] mmcblk1: error -84 transferring data, sector 2048, nr 32, cmd response 0x900, card status 0x0
[ 11.224200] mmcblk1: retrying using single block read

There is no sdmmc slot on developer kit(carrier). What are you trying to do here? Jetpack also not supports it…

I guess that I got the type wrong. I have an MMC slot in the production(??) version of the Nano? It worked when shipped as a second mmc slot, but now after upgrade I had to enable tegra.2 in sdhci to make it visible and to mount it… with those erors.


If your board has an extra emmc, then why do you think jetpack/sdkmanager would support it…?

Jetpack/sdkmanager only supports developer kit carrier board…

You should contact your board vendor for their customization BSP…

FYI, there are differences in an SD card on a module versus on a carrier board. Any update has to preserve the third party manufacturer’s device tree and boot content.

It works, but an initial read on the mounted card results in the CRC errors until the system decides to switch to single reads (as listed at the end of the error message). I was just doing uprade to 4.6.3, but something must have went wrong after I ran to configure my camera… I see other people complaining as well, but nobody found a satisfying solution. Setting sdhci.tegra.2 to “okay” and playing with mmc-ocr-power reduced the number of messages, but it is not the solution. I threw away the manufacturer documentation :).


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.