Create - skeletal animation import with GLTF?

Just checking if the .GLTF importer in Create is supposed to import skeletal animation or not - I have a scene that I have exported and converted from .FBX (which was giving me issues) and it loads into blender OK (also checked with Babel.js sandbox) but while it loads into Create I’m not seeing any animation - either on the meshes or the underlying skeleton if I enable the skeleton visibility options

I know animation support is somewhat rudimentary right now but is there anyway to obviously check if animation clip data exists on an imported skeleton hierarchy or not in the current UI?

@bold.stelvis GLTF importer in Create indeed supports to import skeletal animation, which may also have issues if the glTF has some unsupported structure. It’s better that you can share your data. Or if you cannot, could you check the following (sorry that it’s not easy to spot it in the UI):

  1. In your layer window, there should be at least two layers: root layer, and other layers under root layer.
  2. Right click on the layer under “root layer” and choose save-as to your local disk. Remember to choose “.usda” as extension.
  3. Open the saved .usda to see if there are any animation data.
    Or have you tried to import .FBX?


thanks for the response

I checked with a simpler example GLTF file I found online and that indeed worked ok in Create (animation was present and correct) - I suspect there is an issue with the asset structure that Create doesn’t like with my original asset (joint hierarchy is not a root node, root parent joint in the skeleton hierarchy is not bound itself, skinned meshes grouped rather than root nodes and under a separate group node) that the other apps I tried it with were more forgiving of.

trying to import the fbx directly will pretty much crash every time but at random points in the export leaving some meshes exported as USD (but not all) and some random files with with weird extensions which suggests the sub thread doing the export just stopped without finishing - Create is still up that point but the conversion obviously did not work correctly

I probably have to do some more work on making sure the fbx file itself is better conformed - I will report back if I find any obvious success conditions there

is there any written help or documentation on what ‘properly conformed’ might generally mean for importing skeletal mesh type assets (from any viable source format)?

Thanks for those feedback. The importer indeed supports that meshes are grouped under a separate node, and root node is not joint. And our goal is to support all kinds of skeletal structure. The limitation currently is that it has limit support to node constraint for FBX. Also, FBX importer right now is more robust but you had crashes when you test it. Sorry for that. We’ll appreciate if you can share a small repro case since we may miss some kind of structures. And can I know which DCC tool you are using for the animation export? And export options?
For your question, we are targeting to support all skeletal animation structure for FBX and glTF.

Thanks for your patience.

yep sure - I will try and package something up for you - is there somewhere I can send it? (I don’t mind sharing directly with you but would not be comfortable sharing on a public forum)

it was originally exported from Maya 2017 using the built in game orientated FBX export workflow ( originally exported to test interop between an example asset from our standard offline pipe to various game engines)

the resulting asset was a bit of a hack as I had to remove a massive bunch of rigging cruft to leave just the bind skeleton and the meshes - its likely there might be some exotic joint transform attributes I have overlooked as a result - Maya can be tricky with that stuff :)

the issue I was having originally has been tracked down to a completely unrelated source - nothing to do with the asset itself and everything to do with me working directly in a dropbox managed directory

seems create does NOT play nicely with dropbox for some reason (possibly dropbox trying to sync files prematurely) - easily avoided but I thought it worth reporting :)

Sorry for late reply as missing notifications. You can share it with Google Drive or Dropbox so I can receive it.

For dropbox issue, can you elaborate the issues?

Thanks for reporting this.

I can’t report much beyond what I already stated - random failures on converting assets pretty much (random in that it would just stop converting at seemingly random points in the conversion process - some meshes converted to USD but not all, skel mesh USD’s malformed etc - different failure points each time)

I was saving assets and converting them directly in a local folder managed and synced by drobox (a pretty usual way of working for me as it means I can pick stuff up easily across multiple computers)

when I stopped doing that and moved the assets to a local folder NOT managed or synced by dropbox all was well - I guess I could go back and see if I can create some sort of log for you :)