Cross Compilation Error with Tutorial


we are having trouble with cross compilation, following the tutorial on:

Besides some Paths being obviously wrong our outdated, with cmake command:

cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_TOOLCHAIN_FILE=…/cmake/Toolchain-V5L.cmake -DVIBRANTE_PDK:STRING=/home/absolut/nvidia/nvidia_sdk/DRIVE_Software_9.0_Linux_hyperion_E3550/DriveSDK/drive-t186ref-linux …

we get following error:

CMake Error: Could not open file for write in copy operation /home/absolut/dw_samples/3rdparty/src/glfw/3.2-screen/src/x11/glfw_config.h.tmp
CMake Error: : System Error: No such file or directory
CMake Error at 3rdparty/src/glfw/CMakeLists.txt:57 (configure_file):
configure_file Problem configuring file

We would appreciate some help with this issue.


Dear cschro,

Could you please refer to below cmake command for this topic?
I think you need to add below bold part in your cmake command. Thanks.

cmake -DCMAKE_BUILD_TYPE=Release \
      -DCMAKE_TOOLCHAIN_FILE=<b>/usr/local/driveworks-2.0/samples</b>/cmake/Toolchain-V5L.cmake \
      -DVIBRANTE_PDK:STRING=/home/Test/nvidia/nvidia_sdk/DRIVE_Software_9.0_Linux_hyperion_E3550/DriveSDK/drive-t186ref-linux \

Hi Steve,

we have set a symbolic link for cmake-directory, so …/cmake/Toolchain-V5L.cmake points to the same file as your suggestion. Tried both, same error.

Cross-Compiling the sample-folder is working though. But trying to compile a hello-world program or any other program in fact produces the error mentioned above…

Dear cschro,

Could you please re-try to build DW with the following steps? Thanks.

  1. mkdir /home/nvidia/dw_samples
  2. cd /home/nvidia/dw_samples
  3. ln -s /usr/local/driveworks/samples/cmake/ cmake
  4. ln -s /usr/local/driveworks/samples/3rdparty/ 3rdparty
  5. cp -r /usr/local/driveworks/samples/src .
  6. cp /usr/local/driveworks/samples/CMakeLists.txt .
  7. vi CMakeLists.txt change if-then-else to set(DRIVEWORKS_DATAPATH “/usr/local/driveworks/data”)