cross compile between ubuntu 14.04 and jetson tk1.

I downloaded the cuda l4t on my jetson, and everything was fine, but when I downloaded the cuda 6.0 toolkit on my Ubuntu it started to have problems.
I followed this directions:
http://devblogs.nvidia.com/parallelforall/nvidia-nsight-eclipse-edition-for-jetson-tk1/

and when I tried to do: “sudo apt-get install g+±4.6-arm-linux-gnueabihf”
it said: “Couldn’t find any package by regex 'g+±4.6-arm-linux-gnueabihf”
I checked and in my Ubuntu there’s the 4.7 version of this, so I downloaded the 4.7 and changed the compiler in the nsight eclipse to read 4.7.
when I did built it wrote: “arm-linux-gnueabihf-g+±4.6: No such file or directory”
and its not letting me to compile it.
I know this package is exist in the Ubuntu 12.04 but how could I make it work on my Ubuntu?
thank you for all your help and sorry for any English mistakes I made.

I don’t use Ubuntu on my host machine so I don’t know which package is current. I use recent linaro tool chains:
http://releases.linaro.org/14.09/components/toolchain/binaries

Try one of those with name “gcc-linaro-arm-gnueabihf-*”.

it still not working but thanks

I faced with your problem too and I’ve solved it with create a symbolic to 4.6 from 4.8 with (on Ubuntu 14.04) sudo ln -s /usr/bin/arm-linux-gnueabihf-g+±4.8 /usr/bin/arm-linux-gnueabihf-g+±4.6 and it compiled with some lib errors which are about jetson’s libs and get all of them by scp (http://devblogs.nvidia.com/parallelforall/nvidia-nsight-eclipse-edition-for-jetson-tk1/ this guide is showing just three of them (and saying we may need other libs for additional samples but I get errors about other libs but maybe it’s my fault because I didn’t delete libs without GLU) and probably you have to link them to libxxxx.so - xxxx-> lib name again using sudo ln -s …) now it is working and I’m controlling the board on Nsight (eclipse) Remote Terminal. Now I’m trying to do debug Jetson on SSH and take the screen with vnc.

Maybe you need use Ubuntu 12.04 on host (it’s recomended for R19)?..

Also, for R21 you can read some known issue with workaround on http://docs.nvidia.com/jetpack-tk1/content/developertools/mobile/jetpack_release_notes.htm (from phrase “If you encounter an error when cross-compiling CUDA samples with Nsight Eclipse Edition, use the following workaround…”)

Also, for onboard compilation, you can use (on board terminal):

sudo apt-get install g++-4.6

It will be install arm-linux-gnueabihf-g+±4.6 and others.

I’ve had a similar issue on my setup. I’m using a 64bit Ubuntu 14.04 as the host. I’ve set it up using the JetKit (21.2). In my case, there was a symlink mismatch between my host and my JetsonTK1. On the host there was a “…4.6” symlink present, pointing (eventually) to the 4.8 version. I created a similar symlink on the JetsonTK1 board, and it compiled successfully.