Cross Compile is failed

I’m trying to construct cross compile environment on my host.
I have tried the instrucrion as following site.
But I failed to compile jetson_multimedia_api/samples/10_camera_recording with the message is as bellow.

Linking: camera_recording
aarch64-linux-gnu-g++: fatal error: -fuse-linker-plugin, but not found
compilation terminated.
Makefile:62: recipe for target 'camera_recording' failed
make: *** [camera_recording] Error 1

Host : ubuntu18.04(x86_64)
Target : TX2NX on NX DevKit

Do you observe the failure in building 00_video_decode and 09_camera_jpeg_capture? Would like to know if it is specific to building 10_camera_recording.

Yes. I got the same error in 00_video_decode and 09_camera_jpeg_capture.

I solved this problem.
This issue was caused by an incorrect location where the toolchain was extracted.
I extracted the toolchain to a shared directory on Ubuntu (virtual machine).
As a result, some symbolic links have disappeared.
I extracted the toolchain into an Ubuntu directory (not a shared directory) and the compilation was successful.

I failed to compile the sample 04_video_dec_trt.

/bin/sh: 1: /usr/local/cuda-10.2/bin/nvcc: not found

How to get cuda-compiler(nvcc) it can use for cross-compile on x86_ubuntu ?


You will need to install CUDA and the cross-compile package first.
The package can be automatically installed from the SDK manager.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.