Cross compiling driveworks is not working

I need cMake be 3.21 or later for other programs.

I recommend uninstalling the current cmake version and installing the compatible and verified version from the sdkmanager by proceeding with the installation of the host components.

Regarding cmake version 3.21, please note that it is not officially supported. However, if you still prefer to use it, you can give it a try and address any potential errors that may arise. However, it would be helpful for us to understand the specific reasons behind the need for a cmake version at or above 3.21.

What is the recommended cmake version. I could’t find in the documentation?
We need cmake 3.21 or above for other application.

Can you try running the ‘make’ command to see if you can still build the samples despite encountering these messages? If the build process fails, it would be helpful to ensure that cmake 3.16 is working correctly on your system. It’s worth noting that the cross compilation was tested with cmake 3.16, which is either the default version on Ubuntu 20.04 or installed through sdkmanager.

I can’t downgrade to cmake 3.16. I change to docker. I called
sudo docker run -it --privileged --net=host -v /dev/bus/usb:/dev/bus/usb -v ${WORKSPACE}:/home/nvidiadocker/ from Set Up DRIVE OS Linux with NVIDIA GPU Cloud (NGC) | NVIDIA Docs
I got
“docker run” requires at least 1 argument.
See ‘docker run --help’.

Usage: docker run [OPTIONS] IMAGE [COMMAND] [ARG…]

Create and run a new container from an image
What is missing?
I assume that I have to define ${WORKSPACE}.
I tried WORKSPACE=/home/had/
I tried sudo docker run -it --privileged --net=host -v /dev/bus/usb:/dev/bus/usb -v /home/had:/home/nvidiadocker/ from Set Up DRIVE OS Linux with NVIDIA GPU Cloud (NGC) | NVIDIA Docs

Good to see you create a new topic. Let’s track this issue there.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.