CSGO causes system hang with on-demand driver (470 and 495)


When using the on-demand mode on my GTX1060 Max-Q, CS:GO causes a system hang after few minutes of playing (less than 5min). When going back to the mode NVIDIA (performance mode), the game runs fine.

I am using gamemode to boost performances. It can also enable the GPU while in the on-demand mode by setting the GAMEMODERUNEXEC environment variable. To enable it, I added the following lines in my .profile:

if [ $(prime-select query) == "on-demand" ] ; then 

EDIT: Disabling gamemode doesn’t change anything, the system still freezes.

CS:GO is the only game doing this. I would report it to Valve but I doubt a game could cause a full system hang, so my guess is the problem is related the the driver. I tried disabling the Steam overlay but nothing changed.

The bug happens both on 470 and 495 drivers.

Is anyone else experiencing this issue? What can I do to fix this or to send a bug report to the right place?

CS:GO launch options:
gamemoderun %command% -nojoy -novid

Operating System: KDE neon 5.23
KDE Plasma Version: 5.23.3
KDE Frameworks Version: 5.87.0
Qt Version: 5.15.3
Kernel Version: 5.11.0-40-generic (64-bit)
Graphics Platform: X11
Processors: 4 × Intel® Core™ i5-7300HQ CPU @ 2.50GHz
Memory: 7,7 GiB of RAM
Graphics Processor: Mesa Intel® HD Graphics 630
GPU: NVIDIA GeForce GTX 1060 with Max-Q Design

Report generated after a hard reboot caused by the freeze: nvidia-bug-report.log.gz (394.8 KB)

You’re running it with “nojoy” option, how do you expect to have fun?
Joking aside, please run nvidia-bug-report.sh as root after a freeze and attach the resulting nvidia-bug-report.log.gz file to your post.

You’re running it with “nojoy” option, how do you expect to have fun?

Damn I’ve been doing it wrong the whole time!

Joking aside, please run nvidia-bug-report.sh as root after a freeze and attach the resulting nvidia-bug-report.log.gz file to your post

Thanks for your response! I updated the main post. In case I wasn’t clear, when I say system hang, I mean the whole screen freezes, sound stops, fans slow down, and nothing responds so I must hard reboot the machine. So the report I uploaded is from a hard reboot after the freeze.

I changed the launch options to the following:

$GAMEMODERUNEXEC %command% -nojoy -novid

This way the game starts with the GPU but without gamemode, but it froze as well so the issue is not related to gamemode.

Which version and graphics api are you running csgo under, linux/windows vulkan/opengl?

I run the CS:GO Linux version, so it should use OpenGL.

Ok, simplifies it.
Recent kernels have async flip enabled in the intel driver which leads to errors

[ 327.526] (WW) modeset(0): flip queue failed: Invalid argument
[ 327.526] (WW) modeset(0): Page flip failed: Invalid argument
[ 327.526] (EE) modeset(0): present flip failed

on freezes. Though I don’t know whether this is the reason for the freezes or just a symptom. Did you run a different distro before where this would not happen?

I never used the on-demand for CS:GO before because I had an external monitor attached (which only works in nvidia mode), and I never tried a different distro on this computer.

Seems KDE neon is still based on ubuntu 20.04 (I thought they had switched distros). Please try downgading to the GA (5.4) kernel:

Yes KDE neon uses Ubuntu LTS. I ran into this forum post while searching, seems to be the same issue.

Why not upgrade the kernel? Is the issue still not fixed in 5.11+?

Don’t know, there wasn’t much info to be found and I still don’t know if this is the reason for the freezes or only an additional message in case of freezes, like said.

Downgrading to kernel 5.4 as explained in your link fixed the issue. At least I have a temporary fix thanks!

How can I investigate more into the issue?

Best start would be filing a bug report for the kernel/i915 with ubuntu:

1 Like

I tried with the kernel 5.13 from linux-image-generic-hwe-20.04-edge with corresponding nvidia drivers (linux-modules-nvidia-495-generic-hwe-20.04-edge), and the problem still occurs.

Feared so, since besides the freedesktop.org bug report I couldn’t find anyone working on it or even reporting it.