CSI camera PI module v2 not connected or not working on jetson nano developer 2 gb kit

Hello community,

I’m currently working on a project using the Jetson Nano 2GB Developer Kit and the Raspberry Pi Camera Board v2 (CSI 8-megapixel Sony IMX219). I encountered an issue while trying to check if the CSI camera is working using the following command:

nvgstcapture-1.0

However, when I run this command, a white window appears instead of the expected camera feed. I’ve double-checked the connections and configurations, but I’m still facing this problem.

Has anyone else experienced a similar issue, or does anyone have suggestions on how to troubleshoot and resolve this problem? Any insights or guidance would be greatly appreciated.

Thank you in advance!

I tried following command

v4l2-ctl --list-devices
vi-output, imx219 6-0010 (platform:54080000.vi:0):
/dev/video0

I did also test the cable to make sure it’s fine and it is working.

I checked if any kernel message after runnig the v4l2-ctl to capture data from sensor using following commands

sudo su
echo file csi2_fops.c +p > /sys/kernel/debug/dynamic_debug/control

When I also try to run v4l2-ctl --stream-mmap --set-ctrl bypass_mode=0
Nothing seems to happen:

image

What can be the issue ??

executed few commands for getting live feed of Raspberry Pi v2 CSI camera on Jetson Nano 2GB developer kit ( Jetpack 4.6.1). I am attaching documents for troubleshooting.
Jetson_csi_issues (1).pdf (175.4 KB)
klogs (2).txt (54.9 KB)

We have attempted additional commands to obtain a live feed from the Jetson Nano 2GB board using the Raspberry Camera Module V2. The command list and the corresponding results are attached. Previously, the display showed a white screen, but now it displays the following. I have tried using the GitHub repository at MIPI_Camera/Jetson at master · ArduCAM/MIPI_Camera · GitHub
Please suggest a solution for resolving this issue.
CSI_github.pdf (101.2 KB)

hello sachin.gaikwad,

according to the results in previous comment #3.
it looks you’ve already fetching camera streaming via V4L2 IOCTL.

please try nvarguscamerasrc for checking sensor frame-rate only besides running nvgstcapture-1.0,
for example,
$ gst-launch-1.0 nvarguscamerasrc sensor-id=0 ! 'video/x-raw(memory:NVMM),width=1920, height=1080, framerate=30/1, format=NV12' ! nvvidconv ! 'video/x-raw(memory:NVMM),format=I420' ! fpsdisplaysink text-overlay=0 video-sink=fakesink sync=0 -v

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.