CSI camera stops working after enabling I2S

Background: I am using a Jetson Nano Dev Kit with an e-CAM24_CUNX camera module through the CSI header. I am also using an Adafruit SPH0645LM4H microphone.

Situation: I recently upgraded from JetPack 4.4.1 to 4.6.1 to test a new camera driver from the vendor. At some point after I got the system back up and running with the updated camera driver, my microphone stopped working. I ran sudo /opt/nvidia/jetson-io/jetson-io.py to reconfigure the 40 pin header for the SPH0645LM4H, rebooted, and verified the microphone was working by executing arecord -D hw:tegrasndt210ref,0 -r 44100 -f S32_LE -c 1 -d 10 test.wav. Everything sounds good, but now my camera doesn’t show up in ls /dev/video*. Also, when I run dmesg after booting, this relevant message pops up: " ar0234 : loading out-of-tree module taints kernel." (ar0234 is the e-con camera).

I tried reinstalling the camera driver, but that didn’t do anything. When I delete the “/boot/tegra210-p3448-0000-p3449-0000-b00-user-custom.dtb” file from and reboot, the camera reappears but the mic doesn’t work again.

Am I doing anything obviously wrong here?

I did notice that on my other board running JetPack 4.4.1, running sudo /opt/nvidia/jetson-io/config-by-hardware.py -n "Adafruit SPH0645LM4H" saves the configuration to “/boot/tegra210-p3448-0000-p3449-0000-b00-adafruit-sph0645lm4h.dtb”

But running the same command on JetPack 4.6.1 saves the configuration to “/boot/tegra210-p3448-0000-p3449-0000-b00-user-custom.dtb”

Could that be the issue?

I would suggest consult with E-CON to get the dtbo file for jetson-io to enable the camera.

https://docs.nvidia.com/jetson/archives/l4t-archived/l4t-3261/index.html#page/Tegra%20Linux%20Driver%20Package%20Development%20Guide/hw_setup_jetson_io.html#wwpID0E03B0HA

1 Like

Just updating this thread: I consulted with E-CON per @ShaneCCC’s suggestion and they were able to provide an updated driver with the correct GPIO pin configuration to work with the SPH0645LM4H microphone.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.