CSI IMX708 camera install problem in Jetson Xavier NX

I tried to install 2 CSI camera on Jetson Xavier Nx (recomputer j2022). I had these issues:
I ran “v4l2-ctl --list-devices --list-formats” The result is :

NVIDIA Tegra Video Input Device (platform:tegra-camrtc-ca):
/dev/media0

vi-output, imx708 9-001a (platform:tegra-capture-vi:1):
/dev/video0

vi-output, imx708 10-001a (platform:tegra-capture-vi:2):
/dev/video1

ioctl: VIDIOC_ENUM_FMT
Type: Video Capture

[0]: 'RG10' (10-bit Bayer RGRG/GBGB)

When I ran “nvgstcapture-1.0”, I got this error:
(nvgstcapture-1.0:26153): ERROR **: <create_csi_cap_bin:2185> Element nvarguscamerasrc creation failed

How about argus APP like argus_camera or nvargus_nvraw?

I worked with nvargus_nvraw and the results are these

nvargus_nvraw --lps

nvargus_nvraw version 1.14.0
Number of supported sensor entries 3
Entry Source Mode Uniquename Resolution FR BitDepth Mode
Index Index Index CSI Dyn Type
0 0 0 jakku_rear_RBPCV3 4608x2592 14 10 10 Bayer
1 0 1 jakku_rear_RBPCV3 2304x1296 55 10 10 Bayer
2 0 2 jakku_rear_RBPCV3 1536x 864 90 10 10 Bayer

nvargus_nvraw --file /home/sample.nvraw --exp0 “0.034, 5”

nvargus_nvraw version 1.14.0
capture: Total captured frame count 90
(“nvargus_nvraw”) Error BadParameter (0x04): Embedded data size (16,384) is not a perfect multiple of
row width (9,216)
(in capture_nvraw/src/mobile/ArgusNvRawInterface.cpp, func getPrivateMetadata(),
line 337)
(“nvargus_nvraw”) Error BadParameter (0x04): (propagating from capture_nvraw/src/mobile/ArgusNvRawInterface.cpp,
func addFrame(), line 244)
(“nvargus_nvraw”) Error BadParameter (0x04): (propagating from capture_nvraw/src/mobile/ArgusNvRawCapture.cpp,
func acquireFrames(), line 872)
(“nvargus_nvraw”) Error BadParameter (0x04): (propagating from capture_nvraw/src/mobile/ArgusNvRawCapture.cpp,
func capture(), line 817)
(“nvargus_nvraw”) Error BadParameter (0x04): Unable to capture (propagating from capture_nvraw/src/mobile/main.cpp,
func main(), line 97)

Looks like your sensor output embedded data lines different with the pixel data line cause nvargus_nvraw failed.

Please check with argus_camera.

Hi
Actually I do not have argus_camera. I have installed JetPack 5.1.3 for Jetson Xavier Nx with all possible libraries in SDKManager. Do I need to install argus_camera?

I clone argus_camera from this address and follow the whole instructions

I also changed

set(TegraMM_ROOT $ENV{HOME}/tegra_multimedia_api)

to

set(TegraMM_ROOT $ENV{HOME}/jetson_multimedia_api)

and then tried to build it. But I got this error:
fatal error: Argus/Argus.h: No such file or directory
I don’t know how can I install argus_camera for Jetson Xavier Nx in JetPack 5.1.3

sudo apt list -a nvidia-l4t-jetson-multimedia-api
sudo apt install nvidia-l4t-jetson-multimedia-api=35.xxxxxx

Hi
I installed Jetson-multimedia-api already and there is usr/src/jetson-multimedia-api folder but still argus_camera doesn’t work. I don’t know how can I install argus_camera in Jetson Xavier Nx

Do you follow the README to build the argus_camera and still not working?

If yes, please confirm the sensor driver by v4l2-ctl.

for example

v4l2-ctl --set-fmt-video=width=1920,height=1080,pixelformat=RG10 --set-ctrl bypass_mode=0 --stream-mmap --stream-count=100 
1 Like

argus_camera is installed but still IMX708 is not detected

Please verify the sensor driver by v4l2-ctl first.

https://docs.nvidia.com/jetson/archives/r35.4.1/DeveloperGuide/text/SD/CameraDevelopment/SensorSoftwareDriverProgramming.html#verifying-the-v4l2-sensor-driver

1 Like

I have installed the driver of IMX708 from this website:
https://docs.arducam.com/Nvidia-Jetson-Camera/Native-Camera/Quick-Start-Guide/
and that is working

Yes that is resolved

1 Like