CSI2 Capture Error - CSIMUX_STREAM Event


We are trying to capture from an FPGA that is constantly sending data through 2-lane MIPI channels.

We are not able to capture, but we identified the issue by enabling the debug tracer and parsing the error using TRM:

Testing CSI-C port:

kworker/0:3-2533  [000] ...1   278.013786: rtcpu_vinotify_handle_msg: tstamp:8798033531 tag:CSIMUX_STREAM channel:0xff frame:0 vi_tstamp:208098464 data:0x00000100

The error is notified in bit 8 (data:0x00000100):

Testing CSI-D port:

kworker/3:3-268   [003] ...1   217.967100: rtcpu_vinotify_handle_msg: tstamp:6937644691 tag:CSIMUX_STREAM channel:0xff frame:0 vi_tstamp:2642676924 data:0x00001000

The error is notified in bit 12 (data:0x00001000):

Based on the this, we are getting SPURIOUS_DATA_STREAM errors in the respective CSI channels.

TRM give the following description of this error:
“STREAM_SPURIOUS, which reports that the next packet after a frame end was not a frame start.”

We have checked that MIPI signals from the FPGA reach the TX2 using an oscilloscope. However, it seems that the signal that comes from the FPGA is received by the TX2, but it’s not detected correctly.

We are using a simple driver that just creates the video devices and we confirmed that it works using a different sensor.

  1. Do you know what could be causing this issue?
  2. How the MIPI signals could be affected?
  3. Is there a device-tree related configuration that we could check?

Thanks in advance,

hello EnriqueR,

  1. since you’re working with a FPGA device to send MIPI signaling into CSI.
    may I know were you able to enable test-pattern-generator to narrow down the issue.
  2. some experience shows that there might be additional metadata embedded into streaming, please also checking with oscilloscope.

Hi Jerry,

Thank you for your answer.

I wonder if you can take a look to the MIPI setup that we are currently using and see if you find something wrong with this configuration that is causing the ‘SPURIOUS_DATA_STREAM’ issue.

I attached here a document containing the FPGA-MIPI setup.

Let me know if you can give some help on this.
Thank you,



hello EnriqueR,

could you please configure the video packet as RAW10 for testing, or you should extend support formats for RAW8. please refer to Topic 1015837 for RAW8 capture settings.

also, you might check this similar topic, such as Topic 1050604 which working with a CSI bridge driver (it’s a long discussion thread) for reference.

Hi EnriqueR,

Were you able to fix this issue?

I am having the same error with an FPGA transmitting RGB888 test data to the TX2.



Hi laurence.donkers,

No, I we tried different configurations without success.