ctxgfx.exe High CPU Usage - NVIDIA Grid K1

We deployed XenDesktop 7.1, Xenserver 6.2 with NVIDIA Grid K1, VMs are Windows 7 (32 bit).

ctxgfx.exe uses High CPU even for simple graphics stuff, like watching youtube videos.
We have an escalated open case to Citrix but it more than 3 months now and still have to solution.

Hoping that somebody have already encountered this issue and have a solution.

Thanks you very much.

Do you have HDX enabled? You also didn’t mention which edition of XenDesktop you have installed (Enterprise? Platinum?). Are all the right patches and hotfix installed? What driver version do you have installed? Are you running the VMs using vGPU settings, and if so, which format(s)?
Regarding “high CPU load,” what number do you consider high? 50% of two CPUs or more is fairly normal, even with a GRID at work. Note that not all video will translate optimally to DirectX or OpenGL, plus it also depends what you are using as clients (do they have their own GPU or does the server have to do all the graphics formatting and push it to the video device)?

Hi Tobias,

Yes HDX is enabled (No CPU issue if we do not use HDX), we have Xendesktop Platinum, Patches 1,2 and 4 are installed, did not installed patch 3 because of mouse issue that this patch introduce. NVIDIA Driver is 331.30-332.07, VGPU is K100.

Regarding the CPU load actually even on idle it does not go down less than 10% and once watching simple youtube videos 40$-50% load on a 4 vCPU VM, we are expiriencing the same CPU issue on our Thin Client and and FAT clients.

Base it our escalated case to Citrix, they acknowledge it as a bug, but it’s already three months now and still no resolution, was hoping that other might have a workaround.

Thank you very much,

Hi…
You might upgrade to NVIDIA-vgx-xenserver-6.2-331.59.i386.rpm which came out in March 2014. For our Windows 7 VMs we use 332.83_grid_win8_win7_64bit_english.exe which came out around the same time (we do, however, run 64-bit versions unlike your 32-bit ones). A 64-bit VM is likely going to be more efficient, as well.

Perhaps an upgrade to these newer NVIDIA releases may help your issue?

Regards,