CUBLAS_STATUS_ARCH_MISMATCH for cublasHgemm at VisualStudio 2013 + Gtx1080

How to set system below to run cublasHgemm without CUBLAS_STATUS_ARCH_MISMATCH error?
compute_30,sm_30;compute_50,sm_50
Gtx1080, MSVC2013, Nsight 4.7, cuda7.5, cudnn-v5

FYI, using cuda-rc8+cudnn-v5 also returns the same error.

Setting compute_61,sm_61 cause compilation error.

Use CUDA 8RC, and compile with compute_61,sm_61. Also use cudnn v5.1RC