CUDA 1.1 Error on Quadro NVS 135M

Hello all,

I have a Dell D630 laptop with a Quadro NVS 135M card in it. The 135M is supposed to be (from the CUDA Programming Guide v1.1, Appendix A) a Compute 1.1 Capable Device. I have CentOS 4.6 installed.

I installed the latest linux (169.07) driver, the 1.1 Toolkit, and the 1.1 SDK. Everything appeared to install fine. However, when I went to test it out, I ran into problems. The deviceQuery project in the SDK works fine, but the bandwidthTest did not (in either pinned or unpinned mode). The symptoms that I’m seeing are that when I execute bandwidthTest, it will hang at the command prompt for about 3 seconds after I execute the command. During this time, the mouse (and the entire system) becomes unresponsive. After that, I regain control, but the program exits with a segmentation fault.

I was able to successfully roll back to the 100.xx driver, 1.0 Toolkit, and 1.0 SDK, and the bandwidhTest indeed seems to work. Is there a possiblity that there is a driver bug? Has anyone else tested CUDA 1.1 with an NVS 135M?

Any help would be appreciated.


Not all the included SDK examples will work on this configuration. It only has 128MB of memory and generally CUDA has been tested to require min 256 (this was lowered from the previous release). So some of the examples may work, but we have not setup the examples to detect and work with these smaller memories. You may be able to make some of the problem sizes smaller to still fit. I have seen the bandwidth test fail in 128MB systems. Basically you will be able to do some CUDA programming on here but watch the memory usage carefully.

Hi dhoff,

Thanks for getting back to me. I know that the 135M has limited memory, but the bandwidth Test only tries to allocate a 32 MB block, significantly less than the 128MB available. Furthermore, I wrote a very simple test cuda program, all that it does is use cudamallochost() to allocate a block of memory, print a message, and then de-allocate (free) it. I tried to allocate 1 (one) MB of memory. Under 169.07, it locks up, and then produces a segmentation fault. Under 100.14.11, it runs just fine. Same with the bandwidthTest - works fine under 100.14.11, fails under 169.07.

Again - could this be a driver bug?


Hi dhoff,

I just saw that there was a 169.09 release mentioned in the forums. Is there any chance that there were other fixes included in that release that might help me (other than the 8800 fan issue)?

Also, could you let me know if you think that there is any chance that the 135M issue might be a driver bug?


ok, that’s useful to know that this was working better for you on the older drivers. Were you using CUDA 1.0 with those older drivers ? Didn’t think they’d support CUDA 1.1… So if you were using CUDA 1.0, then we may just be using more memory in 1.1 as well. 128MB is still a tough squeeze.
Driver 169.09 does list a few other fixes that seem worth a with a try. Please let us know if it improves things.

Hi dhoff,

I tried the 169.09 driver and it performs the same as the 169.07 driver. Also, regarding your question about the SDK etc, I have only used v1.1 Tools and SDK with 169.x, and used the v1.0 Tools and SDK when testing with the 100.x driver. In fact, I experienced the problem with 169.07 and tried debugging exclusively with that and v1.1 for a couple of days before it occurred to me to roll back to v1.0 and 100.x.

Hope that helps, please let me know if there are more diagnostics that you need or other ideas that you have.


Hi dhoff,

I just wanted to see if this has been confirmed as a driver bug in the 169.x series drivers. If you could let me know the status I’d appreciate it.


Hi everyone,

I got a similar laptop NVIDIA card, Quadro NVS 135M, on a DELL laptop running Fedora and the 169.09 device driver. However I am for now unable to use it. The card as 256 MB memory but only 128 MB available for CUDA according to the device query thing, All the CUDA toolkit tests failed except the device query one. A simple testcase :

/* Basic NVIDIA CUDA support test. */

#include <stdio.h>

#include <cuda_runtime.h>

#include "cutil.h"


main (void)


  printf("Basic CUDA test\n");


 char* buffer = NULL;

  int size = 1024;

  printf("Allocating %d bytes\n", size);

  CUT_SAFE_MALLOC(cudaMalloc((void**) &buffer, size));

  printf ("CUDA buffer allocated at %p\n", buffer);

 return 0;


This code reports no error but freeze the computer for some seconds (or forever) and may segfault or return a null pointer.

I would enjoy testing it with a CUDA 1,0 device driver but it seems that my last try with 100.x was unable to find a CUDA device. I would enjoy manipulating drivers but i cannot be root on this computer.

And yes, downgrading to CUDA 1.0 works for me too.

I have too a Quadra NVS 135M (256Mo ) on DELL laptop with opensuse 10.3, gcc 4.2.1, and

cuda 1.1 with driver 169.09.

I’ve tried the testcase above which failed with the

following message :

There is no device supporting CUDA.

The nvidia module is probed…

Any idea with this problem ?

Is a correction planned for cuda with this GPU in next version ?

Thanks a lot !

NB : The device problem is solved ( wrong drivers ). I have the freezing problem too with Cuda 1.1…