CUDA 10.0 - but Could not load dynamic library 'cudart64_101.dll'

I have this problem: I installed CUDA 10.1 update 1-it gives an error: “Black gem launch failed”. I reinstalled CUDA 10.0 and started getting the error “failed to load the dynamic library’ DLL’”.
A GeForce GTX 1060 3GB video card is installed.
I have been trying to solve this problem for 2 days((( I dance with tambourines, a rabbit’s foot hangs around my neck - it Doesn’t help((
Question-why does the system ask cudart64_101.dll, although CUDA 10.0 is installed? but what about cudart64_100.dll? the system doesn’t need this file?

My OS: Windows 8.1

CUDA 10.0 installed (CUDA 10.1 was the same): nvidia-smi

| NVIDIA-SMI 425.25       Driver Version: 425.25       CUDA Version: 10.1     |
| GPU  Name            TCC/WDDM | Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|   0  GeForce GTX 106... WDDM  | 00000000:08:00.0  On |                  N/A |
|  0%   40C    P8     5W / 120W |    372MiB /  3072MiB |      1%      Default |

| Processes:                                                       GPU Memory |
|  GPU       PID   Type   Process name                             Usage      |
|    0       752    C+G   Insufficient Permissions                   N/A      |
|    0      1924    C+G   C:\Windows\Explorer.EXE                    N/A      |
|    0      8156    C+G   ...rogram Files\Microsoft VS Code\Code.exe N/A      |

the error “Black gem launch failed” appears when I use keras-function: model.predict()

I did the cuda-installation according to the instructions:

I compiled samples: deviceQuery, bandwidthTest and simpleCUBLAS. deviceQuery and simpleCUBLAS - pass ok. bandwidthTest - failed

print(tf.__version__): 2.3.1

I tried:
import tensorflow as tf
physical_devices = tf.config.list_physical_devices('GPU') tf.config.experimental.set_memory_growth(physical_devices[0], True)

not working for me(

I rollback CUDA 10.1 and downgraded Tensorflow to version 2.2.0 - everything works fine. But i have another problem(((
When I run the program for the first time, it works fine. But after restarting - I get the message - Black gem launch failed. If I restart Visual Studio Code, the first run is successful again. but the second run failed again.

I tried to do the following:

from keras import backend as K

del model

from numba import cuda

This didn’t help for me