CUDA 10.1/2 x86_64 run file installation issue

I got a similar issue to CUDA 10.1.243 (10.1 update 2) ppc64le run file installation issue on a fresh x86_64 Fedora 32 installation. Any ideas on how to fix it and to get Cuda running?

I tried Cuda versions 10.1 Update 1, 10.1 Update 2, and 10.2 - all fresh downloaded.

What I found in the log file: /var/log/cuda-installer.log

First everything fine with:

[INFO]: cuda-gdb
[INFO]: Successfully created directory: /var/log/nvidia/.uninstallManifests/CUDA_Toolkit_10.2-components/CUDA_Tools_10.2-components/CUDA_Command_Line_Tools_10.2-components/
[INFO]: Successfully created directory: /usr/local/cuda-10.2/extras
[INFO]: Successfully created directory: /usr/local/cuda-10.2/extras/Debugger
[INFO]: Successfully created directory: /usr/local/cuda-10.2/share

Second some Skipping copy:

[INFO]: Installed: /usr/local/cuda-10.2/targets/x86_64-linux/include/thrust/device_new_allocator.h
[INFO]: Installed: /usr/local/cuda-10.2/targets/x86_64-linux/include/thrust/generate.h
[INFO]: Skipping copy. File already exists at: /usr/local/cuda-10.2/targets/x86_64-linux/include/cusolverMg.h
[INFO]: Installed: /usr/local/cuda-10.2/targets/x86_64-linux/include/cublasLt.h
[INFO]: Skipping copy. File already exists at: /usr/local/cuda-10.2/targets/x86_64-linux/include/curand_mtgp32.h
[INFO]: Installed: /usr/local/cuda-10.2/targets/x86_64-linux/include/sm_30_intrinsics.hpp
[INFO]: Skipping copy. File already exists at: /usr/local/cuda-10.2/targets/x86_64-linux/include/nppi_statistics_functions.h
[INFO]: Installed: /usr/local/cuda-10.2/targets/x86_64-linux/include/cuda_gl_interop.h
[INFO]: Installed: /usr/local/cuda-10.2/targets/x86_64-linux/include/sm_20_atomic_functions.hpp
[INFO]: Skipping copy. File already exists at: /usr/local/cuda-10.2/targets/x86_64-linux/include/cufft.h
[INFO]: Skipping copy. File already exists at: /usr/local/cuda-10.2/targets/x86_64-linux/include/cuda_fp16.hpp
[INFO]: Skipping copy. File already exists at: /usr/local/cuda-10.2/targets/x86_64-linux/include/cuda_fp16.h
[INFO]: Skipping copy. File already exists at: /usr/local/cuda-10.2/targets/x86_64-linux/include/host_defines.h

Finally a cleanup that accually removes everything except some hidden folder @ /var/log/nvidia/.uninstallManifests

[INFO]: md5 matches, removing file /var/log/nvidia/.uninstallManifests/
[ERROR]: boost::filesystem::remove: Directory not empty: "/var/log/nvidia/.uninstallManifests/"
[INFO]: Removing symlink: /usr/local/cuda
[INFO]: md5 matches, removing file /var/log/nvidia/.uninstallManifests/
[ERROR]: boost::filesystem::remove: Directory not empty: "/var/log/nvidia/.uninstallManifests/"
[INFO]: md5 matches, removing file /var/log/nvidia/.uninstallManifests/
[ERROR]: boost::filesystem::remove: Directory not empty: "/var/log/nvidia/.uninstallManifests/"

What did I execute?

sudo ./cuda_10.2.89_440.33.01_linux.run --override

  • accepted EULA
  • disabled driver, samples, demo and documentation

Driver Version 440.82 in use with an GTX 1080Ti:

╰─$ nvidia-smi                                                                                                          
Tue Jun  2 21:55:55 2020       
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 440.82       Driver Version: 440.82       CUDA Version: 10.2     |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|===============================+======================+======================|
|   0  GeForce GTX 108...  Off  | 00000000:09:00.0  On |                  N/A |
|  0%   60C    P0    66W / 250W |    721MiB / 11175MiB |      0%      Default |
+-------------------------------+----------------------+----------------------+

Maybe you can try:
sudo ./cuda_…_linux.run --librarypath=/usr/local/cuda-10.2

… represents your version of cuda