CUDA 10.1 with 2070 Super on Ubuntu 18.04

I’ve tried to install new nvidia driver 430 for support of my new 2070 Super on Ubuntu 18.04, on top an existing CUDA 10.1 installation (deb local) with 418 driver.

However it seems the dependencies are hardcoded to driver 418 which makes it impossible to install new driver:

sudo apt-get install nvidia-driver-430 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
 nvidia-driver-430 : Depends: libnvidia-gl-430 (= 430.26-0ubuntu0~gpu18.04.1) but it is not going to be installed
                     Depends: nvidia-dkms-430 (= 430.26-0ubuntu0~gpu18.04.1) but it is not going to be installed
                     Depends: nvidia-kernel-source-430 (= 430.26-0ubuntu0~gpu18.04.1) but it is not going to be installed
                     Depends: nvidia-compute-utils-430 (= 430.26-0ubuntu0~gpu18.04.1) but it is not going to be installed
                     Depends: libnvidia-decode-430 (= 430.26-0ubuntu0~gpu18.04.1) but it is not going to be installed
                     Depends: libnvidia-encode-430 (= 430.26-0ubuntu0~gpu18.04.1) but it is not going to be installed
                     Depends: xserver-xorg-video-nvidia-430 (= 430.26-0ubuntu0~gpu18.04.1) but it is not going to be installed
                     Depends: libnvidia-cfg1-430 (= 430.26-0ubuntu0~gpu18.04.1) but it is not going to be installed
                     Depends: libnvidia-ifr1-430 (= 430.26-0ubuntu0~gpu18.04.1) but it is not going to be installed
                     Recommends: libnvidia-decode-430:i386 (= 430.26-0ubuntu0~gpu18.04.1)
                     Recommends: libnvidia-encode-430:i386 (= 430.26-0ubuntu0~gpu18.04.1)
                     Recommends: libnvidia-ifr1-430:i386 (= 430.26-0ubuntu0~gpu18.04.1)
                     Recommends: libnvidia-fbc1-430:i386 (= 430.26-0ubuntu0~gpu18.04.1)
                     Recommends: libnvidia-gl-430:i386 (= 430.26-0ubuntu0~gpu18.04.1)
E: Unable to correct problems, you have held broken packages.

Any plans to fix this?

Thanks.

nvidia-driver-430 isn’t packaged or controlled by nvidia - its from ppa, right?

https://docs.nvidia.com/cuda/cuda-installation-guide-linux/index.html#package-manager-upgrades

It’s from PPA yes. Is there a CUDA repo with 430 driver already available? Because I didn’t see it for download…

FYI https://devtalk.nvidia.com/default/topic/1063008/cuda-setup-and-installation/is-the-418-driver-from-the-cuda-ppa-supposed-to-support-super-cards-/post/5382993/#5382993