Cuda 10 Install - My Experience

I am documenting what I went through installing Cuda 10 on my Lenovo P71 with a docking station and 2 external displays, hoping it will help someone down the road.

My system has Windows 10 Pro with a Quadro P3000, driver version 398.36.

Yesterday I went to the Cuda download link and downloaded the local install executable and ran it, followed the instructions and selected the Express install option. Since I knew nothing about Cuda and what it needed I let the installer do what it thought was best. As it was proceeding, at some point the installer says something about the display(s) blinking during installation, which makes sense since it is overwriting the display drivers. Unfortunately for me, the displays went to black and did not return. (Note that my default configuration, and the one I was using during the install, is the P71 docked with lid closed and using the 2 external HDMI connected displays, a usb keyboard and usb mouse.)

After waiting for some time, I noticed that the red LED on the laptop lid was lit, so it was still ON. I knew from past experience that sometimes the laptop and dock would lose connection to the external displays but the laptop would still be on, so I opened the laptop lid and it was running. However, it no longer could see either of my external displays and when I tried to run nView Desktop Manager, it never opened, it just failed silently.

I restarted the system several times to no avail. My system had no idea about the external displays and would not run the Nvidia nView Desktop Manager.

I looked to see how I could uninstall Cuda 10, but there didn’t seem to be an option in the Nvidia tab of the Programs list to undo everything that I had just done. There are 13 items in the Nvidia list and only 5 are apps that can be uninstalled and none of these appeared to be the magic “Undo what I just did” option. I then looked in the control panel and found 15 new Nvidia items that could all be uninstalled but that did not seem to be a good thing to try to do without any more knowledge that I had.

The approach I took was to take Windows back to its previous “restore point” using Windows Restore, since the only thing I had done was install Cuda. (It is possible that I could have just gone to Device Manager and rolled back the Nvidia driver but I didn’t think about doing that until after I had done this.) I initiated the restore back to the previous restore point and then waited about 30 nervous minutes after which the system restarted fine and the Cuda stuff was gone except for the apps in the Nvidia tab mentioned above. I uninstalled those individually.

After perusing this forum and talking to a co-worker who had recently successfully installed Cuda on a newer Lenovo laptop, I found that my current driver version, 398.36, would not support Cuda 10.

I tried to update the driver to the latest driver thru Windows but it said that I had the latest.

I checked the Nvidia site and found that the latest driver from there was version 419.17 which supported Cuda 10 and I successfully installed that driver from the Nvidia site.

Then I went back and tried to install Cuda 10 again using the executable that I had already downloaded. After it checked the configuration, I got a warning that “You are installing an older driver version. The system may install a newer version when the computer is docked or undocked.”

At that point I searched this forum and found https://devtalk.nvidia.com/default/topic/1028688/cuda-setup-and-installation/you-are-installing-an-older-driver-version-the-system-/. After reading it I decided to proceed and ended up at the screen that allows you to select Express or Custom install. I selected Custom and then unchecked all of the items that showed that I had a more recent version than what the installer had and then proceeded.

The installed finished and seems to have installed everything without incident.

I have yet to test things out, since I decided to write this while it was still fresh but will update this if there are any other problems as I try to now use Cuda.

I hope this is helpful to someone.

Thanks for sharing!

While things looked to have installed correctly neither my Visual Studio 2015 or 2017 can create a Cuda project.

In VS 2015 I get the following error during the New Project… creation:

[i]Failed to create project

Unable to read the project file “CUDA_Test.vcxproj”.
c:\Users\larry\documents\visual studio
2015\Projects\CUDA_Test\CUDA_Test\CUDA_Test.vcxproj(96,2):
The imported project “C:\Program Files
(x86)\MSBuild\Microsoft.Cpp\v4.0\BuildCustomizations\CUDA
10.0.targets” was not found. Confirm that th epath in the
declaration is correct, and that the file exists on disk.[/i]

When I look at the directory “…\v4.0\BuildCustomizations|”, there are no CUDA files. However I did find the CUDA files in “C:\Program Files(x86)\MSBuild\Microsoft.Cpp\v4.0\V140\BuildCustomizations” and they were the only new files in that directory dated the day of the Cuda install. So I copied all of those files into the directory that VS15 was looking and it then appears to have created a CUDA project. I built and ran the project successfully.

With regards to VS 2017, when I attempted to create a new CUDA project, it creates a new project that is empty. I don’t yet know how to deal with that.

After the previous post I checked the forum and noticed some comments about Cuda working with certain update versions of VS 17.

I was running VS 2017 Community edition version 15.8.8. I checked for updates and saw that the current version is 15.9.7 and updated my installation.

After installing the update, I attempted to create a new CUDA project and it succeeded. I was able to build and debug the project.

So, things seem to be working now.

Thank you Larrycook99

I hope this is helpful to someone.
It was helpful, in particular the “you are installing and older driver version…” which was perplexing.