Cuda 10 installation from zypper/rpm on OpenSuse 15.0 broken depmod

When I install cuda 10 on OpenSuse 15.0 following the published instructions:
rpm -i cuda-repo-opensuse15-10.0.130-1.x86_64.rpm;zypper refresh;zypper install cuda

I receive the following error message:
Additional rpm output:
depmod: ERROR: fstatat(5, nvidia-drm.ko): No such file or directory
depmod: ERROR: fstatat(5, nvidia-modeset.ko): No such file or directory
depmod: ERROR: fstatat(5, nvidia-uvm.ko): No such file or directory
depmod: ERROR: fstatat(5, nvidia.ko): No such file or directory

as a result the nvidia driver does not load with
modprobe nvidia
modprobe: ERROR: could not find module by name=‘nvidia’
modprobe: ERROR: could not insert ‘nvidia’: Unknown symbol in module, or unknown parameter (see dmesg)

running depmod manually results in the same error as above

loading the modules with insmod works
insmod /lib/modules/4.12.14-lp150.12.22-default/updates/nvidia.ko
insmod /lib/modules/4.12.14-lp150.12.22-default/updates/nvidia-uvm.ko

after which nvidia-smi works
| NVIDIA-SMI 410.48 Driver Version: 410.48 |
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
| 0 GeForce GTX 106… Off | 00000000:01:00.0 Off | N/A |
| 0% 38C P0 25W / 120W | 0MiB / 6077MiB | 5% Default |

| Processes: GPU Memory |
| GPU PID Type Process name Usage |
| No running processes found |

kernel version is

the same error happened on two different servers

please let me know if further info is required