CUDA 10 installation on Ubuntu 16.04

Hello All,

I am trying to install CUDA 10 on Ubuntu 16.04 using the run file method.
CUDA gets installed successfully but the drivers are not installed.
When I run “nvidia-smi” - I get the error “cant communicate with the driver”.

System details:

uname -r
4.4.0-040400-generic

uname -m
x86_64

Ubuntu 16.04.5
GPU: Titan XP
The latest drivers should be 410.48 according to NVIDIA

I ran the run file after clearing my system of all preexisting nvidia drivers and early cuda versions.

Here is the log in the nvidia-installer.log:

nvidia-installer log file ‘/var/log/nvidia-installer.log’
creation time: Thu Jan 3 18:15:44 2019
installer version: 410.48

PATH: /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/snap/bin

nvidia-installer command line:
./nvidia-installer
–ui=none
–no-questions
–accept-license
–disable-nouveau
–no-cc-version-check
–dkms

Using built-in stream user interface
-> Detected 40 CPUs online; setting concurrency level to 32.
-> Installing NVIDIA driver version 410.48.
-> Running distribution scripts
executing: ‘/usr/lib/nvidia/pre-install’…
-> done.
-> The distribution-provided pre-install script failed! Are you sure you want to continue? (Answer: Continue installation)
WARNING: One or more modprobe configuration files to disable Nouveau are already present at: /etc/modprobe.d/nvidia-installer-disable-nouveau.conf. Please be sure you have rebooted your system since these files were written. If you have rebooted, then Nouveau may be enabled for other reasons, such as being included in the system initial ramdisk or in your X configuration file. Please consult the NVIDIA driver README and your Linux distribution’s documentation for details on how to correctly disable the Nouveau kernel driver.
-> For some distributions, Nouveau can be disabled by adding a file in the modprobe configuration directory. Would you like nvidia-installer to attempt to create this modprobe file for you? (Answer: Yes)
-> One or more modprobe configuration files to disable Nouveau have been written. For some distributions, this may be sufficient to disable Nouveau; other distributions may require modification of the initial ramdisk. Please reboot your system and attempt NVIDIA driver installation again. Note if you later wish to reenable Nouveau, you will need to delete these files: /etc/modprobe.d/nvidia-installer-disable-nouveau.conf
-> Would you like to register the kernel module sources with DKMS? This will allow DKMS to automatically build a new module, if you install a different kernel later. (Answer: Yes)
-> Installing both new and classic TLS OpenGL libraries.
-> Installing both new and classic TLS 32bit OpenGL libraries.
-> Install NVIDIA’s 32-bit compatibility libraries? (Answer: Yes)
-> Will install GLVND GLX client libraries.
-> Will install GLVND EGL client libraries.
-> Skipping GLX non-GLVND file: “libGL.so.410.48”
-> Skipping GLX non-GLVND file: “libGL.so.1”
-> Skipping GLX non-GLVND file: “libGL.so”
-> Skipping EGL non-GLVND file: “libEGL.so.410.48”
-> Skipping EGL non-GLVND file: “libEGL.so”
-> Skipping EGL non-GLVND file: “libEGL.so.1”
-> Skipping GLX non-GLVND file: “./32/libGL.so.410.48”
-> Skipping GLX non-GLVND file: “libGL.so.1”
-> Skipping GLX non-GLVND file: “libGL.so”
-> Skipping EGL non-GLVND file: “./32/libEGL.so.410.48”
-> Skipping EGL non-GLVND file: “libEGL.so”
-> Skipping EGL non-GLVND file: “libEGL.so.1”
Looking for install checker script at ./libglvnd_install_checker/check-libglvnd-install.sh
executing: ‘/bin/sh ./libglvnd_install_checker/check-libglvnd-install.sh’…
Checking for libglvnd installation.
Checking libGLdispatch…
Can’t load library libGLdispatch.so.0: libGLdispatch.so.0: cannot open shared object file: No such file or directory
Will install libglvnd libraries.
Will install libEGL vendor library config file to /usr/share/glvnd/egl_vendor.d
-> Searching for conflicting files:
-> done.
-> Installing ‘NVIDIA Accelerated Graphics Driver for Linux-x86_64’ (410.48):
executing: ‘/sbin/ldconfig’…
-> done.
-> Driver file installation is complete.
-> Installing DKMS kernel module:
ERROR: Failed to run /usr/sbin/dkms build -m nvidia -v 410.48 -k 4.4.0-040400-generic:
Kernel preparation unnecessary for this kernel. Skipping…

Building module:
cleaning build area…
‘make’ -j32 NV_EXCLUDE_BUILD_MODULES=’’ KERNEL_UNAME=4.4.0-040400-generic IGNORE_CC_MISMATCH=‘1’ modules…(bad exit status: 2)
ERROR (dkms apport): binary package for nvidia: 410.48 not found
Error! Bad return status for module build on kernel: 4.4.0-040400-generic (x86_64)
Consult /var/lib/dkms/nvidia/410.48/build/make.log for more information.
-> error.
ERROR: Failed to install the kernel module through DKMS. No kernel module was installed; please try installing again without DKMS, or check the DKMS logs for more information.
ERROR: Installation has failed. Please see the file ‘/var/log/nvidia-installer.log’ for details. You may find suggestions on fixing installation problems in the README available on the Linux driver download page at www.nvidia.com.

Let me know if anyone knows how to fix this issue.
Thank you.