Cuda 10 Linux installation error: "buffer overflow detected"

Hello Folks,

Recently I got this error (below) when I tried to install cuda 10 on my openSUSE Tumbleweed.
The surprising thing was that even cuda 9 gave me the same error, which I have installed previously.
I know that I have an unlisted system config. But so far I had no problem with it.
Can this be related to “libc 2.27”?
Please if anyone had success let me know and also give me your config details like
kernel version, gcc and glibc versions.

Thanks in advance…


./cuda_10.0.130_410.48_linux.run
Logging to /tmp/cuda_install_6676.log
Using less to view the EULA.
*** buffer overflow detected ***: /usr/bin/perl terminated
./cuda_10.0.130_410.48_linux.run: line 510: 6676 Aborted (core dumped) ./cuda-installer.pl

I am also an openSUSE Tumbleweed user and I am experiencing the same error when attempting to install CUDA 10 Toolkit:

./cuda_10.0.130_410.48_linux

Logging to /tmp/cuda_install_10963.log
Using less to view the EULA.
./cuda_10.0.130_410.48_linux: line 510: 10963 Segmentation fault (core dumped) ./cuda-installer.pl

Few informations regarding my computer:

uname -a
Linux faraday 4.20.2-1-default #1 SMP PREEMPT Sun Jan 13 12:37:46 UTC 2019 (036c5c2) x86_64 x86_64 x86_64 GNU/Linux

gcc -v
Using built-in specs.
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/lib64/gcc/x86_64-suse-linux/8/lto-wrapper
OFFLOAD_TARGET_NAMES=hsa:nvptx-none
Target: x86_64-suse-linux
Configured with: …/configure --prefix=/usr --infodir=/usr/share/info --mandir=/usr/share/man --libdir=/usr/lib64 --libexecdir=/usr/lib64 --enable-languages=c,c++,objc,fortran,obj-c++,ada,go --enable-offload-targets=hsa,nvptx-none=/usr/nvptx-none, --without-cuda-driver --enable-checking=release --disable-werror --with-gxx-include-dir=/usr/include/c++/8 --enable-ssp --disable-libssp --disable-libvtv --disable-cet --disable-libcc1 --enable-plugin --with-bugurl=http://bugs.opensuse.org/ --with-pkgversion=‘SUSE Linux’ --with-slibdir=/lib64 --with-system-zlib --enable-libstdcxx-allocator=new --disable-libstdcxx-pch --enable-version-specific-runtime-libs --with-gcc-major-version-only --enable-linker-build-id --enable-linux-futex --enable-gnu-indirect-function --program-suffix=-8 --without-system-libunwind --enable-multilib --with-arch-32=x86-64 --with-tune=generic --build=x86_64-suse-linux --host=x86_64-suse-linux
Thread model: posix
gcc version 8.2.1 20190103 [gcc-8-branch revision 267549] (SUSE Linux)

nvidia-smi
Mon Jan 28 19:10:28 2019
±----------------------------------------------------------------------------+
| NVIDIA-SMI 410.93 Driver Version: 410.93 CUDA Version: 10.0 |
|-------------------------------±---------------------±---------------------+
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
|===============================+======================+======================|
| 0 GeForce GTX 105… Off | 00000000:01:00.0 On | N/A |
| 31% 39C P0 N/A / 75W | 515MiB / 4032MiB | 4% Default |
±------------------------------±---------------------±---------------------+

±----------------------------------------------------------------------------+
| Processes: GPU Memory |
| GPU PID Type Process name Usage |
|=============================================================================|
| 0 1880 G /usr/bin/X 272MiB |
| 0 3917 G /usr/bin/kwin_x11 103MiB |
| 0 3922 G /usr/bin/krunner 8MiB |
| 0 3924 G /usr/bin/plasmashell 82MiB |
| 0 4590 G /usr/bin/ksysguard 1MiB |
| 0 10826 G /usr/lib/virtualbox/VirtualBox 1MiB |
±----------------------------------------------------------------------------+

Did you happen to read the installation guide?
https://docs.nvidia.com/cuda/cuda-installation-guide-linux/index.html

This distro version is not listed as supported.

Did you happen to read the OP message?

This information that you’re bringing up the OP already brought. Nevertheless, we are trying to make it work on Tumbleweed… There must me some reason, no?

I guess I forgot to add some light shedding details about my experience:
After I downloaded cuda 10, I uninstalled pre-installed cuda 9
Then when I got the “buffer overflow” error for cuda 10 installation I tried to get back to cuda 9
Yet the same “buffer overflow” error appeared. So my guess is that some library update is the issue.
It can be related to perl libraries or to glibc on the latest Tumbleweed.
I would love to hear any solution for that.

I also hope that NVIDIA will come up with a better cuda update scheme.
Reqs are so restricted in the sense of requiring specific kernel, gcc, libc, even distros.
I used to write cuda programs back in the 2010s, but things are changing and our codes are becoming useless.

You are welcome to try whatever you want on your computer, I don’t care. If you choose to use something that was not officially tested, go for it, but don’t complain if it fails to work properly.