cuda 10 on microsoft surface book 2 with windows 10

Hi all,

I launched the cuda local installer (cuda_10.0.130_411.31_win10.exe) on my brand new surface book 2 (windows 10 pro 1803 17134.407).

The installation apparently was ok. From Visual Studio with the cuda plugin I can compile the sample programs, but when I try to run them, I get an error message stating that there is no GPU available.

Any suggestion?

Some surface book 2 with the 13.5" display do not have a NVIDIA GPU:

https://www.microsoft.com/en-us/surface/devices/surface-book-2/tech-specs

Otherwise, if you are sure you have a NVIDIA GPU, it may be a matter of getting that GPU turned on using an optimus profile.

https://www.windowscentral.com/how-force-your-surface-book-use-its-dedicated-gpu-games

Hi Robert, thank you for your reply.

My Surface is a 15" with a gorgeous GTX 1060.

I tried the suggestion from your link, both setting “High performance NVIDIA processor” for the sample executable and then as a global setting, but I keep getting “Error: only 0 devices available, 1 requested. Exiting.”

Regards,

Daniele

I also use CUDA 10 on a Surface Book 2 and had problems with the driver that the CUDA 10 installer uses. After the driver installs I noticed that the 1060 is shown in Device Manager as being in an error state due to the drivers not being signed.

The quickest solution is to just download the latest 1060 Notebook drivers from NVIDIA.com rather than relying on the ones that shipped with the CUDA SDK. After I installed the latest 417.01 drivers and replaced the unsigned ones everything was fine.

Hi ajmiles, thank you.

In the bext days, as soon as I find a slice of time, I am going to try your suggestion – install cuda 10 without driver, then update the driver only, and I’ll report here the result.

By the way – after installation of the latest drivers from nvidia.com, are you still able to detach the screen of the surface book?

Regards,

Daniele

Hi Daniele,

Yes, I have no problems detaching the screen using the latest drivers from nvidia.com.

Adam

OK, this way it works! And no problem (at least for now ;) detaching the screen!

Thank you very much!

Hope this won’t get broken at next Windows Update – must see if it is possible to selectively disable updates for the nvidia gpu.