CUDA 2.2 fails to find device

Running on Macbook pro with following
GeForce 8600M GT:

Chipset Model: GeForce 8600M GT
Type: Display
Bus: PCIe
PCIe Lane Width: x16
VRAM (Total): 256 MB
Vendor: NVIDIA (0x10de)
Device ID: 0x0407
Revision ID: 0x00a1
ROM Revision: 3175
Displays:
Color LCD:
Resolution: 1440 x 900
Depth: 32-bit Color
Core Image: Hardware Accelerated
Main Display: Yes
Mirror: Off
Online: Yes
Quartz Extreme: Supported
Built-In: Yes
Display Connector:
Status: No display connected

When running deviceQuery I get

CUDA Device Query (Runtime API) version (CUDART static linking)
There is no device supporting CUDA.

Device 0: “Device Emulation (CPU)”
CUDA Capability Major revision number: 9999
CUDA Capability Minor revision number: 9999
Total amount of global memory: 4294967295 bytes
Number of multiprocessors: 16
Number of cores: 128
Total amount of constant memory: 65536 bytes
Total amount of shared memory per block: 16384 bytes
Total number of registers available per block: 8192
Warp size: 1
Maximum number of threads per block: 512
Maximum sizes of each dimension of a block: 512 x 512 x 64
Maximum sizes of each dimension of a grid: 65535 x 65535 x 1
Maximum memory pitch: 262144 bytes
Texture alignment: 256 bytes
Clock rate: 1.35 GHz
Concurrent copy and execution: No
Run time limit on kernels: No
Integrated: Yes
Support host page-locked memory mapping: Yes
Compute mode: Default (multiple host threads can use this device simultaneously)

Test PASSED

Press ENTER to exit…

What am I doing wrong? Is my GPU not supported?

Thanks

Reinstall CUDA 2.2, and when you get to the prompt where you can customize the install options, double check that CUDA.kext is actually being installed. This happened on some machines with 2.1.

:thumbup: This worked beautifully … Thanks.

You are completely right.

It works perfectly :thumbup:

I tried to upgrade from 2.1 to 2.2 on my mac pro with gtx 285 and now getting the same error. I made sure the CUDAkext was selected in the installer. What is weird is that I want into the /system/library/extensions folder and saw that the CUDA.kext is from Feb of 08 and checking the system profiler CUDA has a version number of 1.1.0 . Is this an old kext? Is it just ignoring this and using newer ones? I see some NVDANV**Hal.kext’s and a NVDAResman.kext which I assume are the graphics card drivers but nothin else I can identify.

This worked great.

Is there any way to place this in the MacOSX-specific installation guide found at http://www.nvidia.com/object/cuda_get.html? Having this advice there would have saved me several hours today. (The best thing would be to change the default to have CUDA.kext selected by default, IMO. However, rebuilding the installer is probably much harder than just updating the docs.)

THANKS!

It is selected by default on 95% of machines. That’s what’s so maddening about it…