CUDA 2.2 for Snow Leopard? Migration to 10.6

Can anyone say if there is a Mac CUDA 2.2 that will work under Snow Leopard by now? I am moving my dev to 10.6 and wish to work in parallel in CUDA and OpenCL, but the new 2.2 kit seems to be 10.5 only. I have official Snow Leopard access under ADC membership and would like to migrate now. Or is all GPU mac support for this flavour OS X Open CL only. Thanks

Any news on that?
Have you tried installing CUDA 2.2 on SnowLeopard?

I see there’s a new SL build on ADC and I’m tempted to try it out - but only if CUDA works with it.

When I last tried 2.2 under Snow a couple of weeks ago I got all sorts of wierd errors to do with the library stuff having the wrong structure. I must confess that under Snow Leopard I had started instead to try the OpenCL stuff, and last night had my first go at porting some of the Nvidia Windows OpenCL examples to Snow projects under Xcode (I did not get very far but it was late!). I have not updated my Snow seed for a while so will probably get that and see if it makes any difference.

(hope this does not break any NDA…) I installed CUDA 2.2 on the last SL seed. Installation went fine but the CUDA SDK samples do not compile - all kinds of errors - as you wrote.

I guess we have to cross our fingers and hope CUDA 2.3 will add SL compatibility.

Best regards

I sort of get the feeling that OpenCL is regarded as the way forward for SL stuff, so I am not now counting on CUDA support myself. I just wish there were more widely available examples of OpenCL under SL - I need a rich set of examples before I can get going.

I’ve played a bit with OpenCL on SL some weeks ago and I could not get anything near CUDA performance. Slow Host<->Device transfers, slow Device<->Device transfers, etc. My impression was that OpenCL will take some time to run as smooth as CUDA. So for the project we are starting now we have decided to use CUDA. Since CUDA programs can be so easily adapted to OpenCL for me that seemed the best choice.

Anyway, it’s really nice to see so much happening. The NVIDIA Windows OpenCL implementation also shows steady improvement. Great.
I will never miss the OpenGL shader ping pongs :)

I’ve looked at CUDA 2.2 on SL again. It looks like nvcc is having trouble to compile the new SL headers with support for BLOCKS.

The make output shows errors compiling stdlib.h and if one looks at where the errors are thrown you’ll see it’s inside #ifdef BLOCKS … So it looks like NVIDIA needs to update nvcc.

Besides, I was able to compile a minimal test app that just queries for CUDA devices (compiling it with GCC, linked to libcudart). On the output I am not seeing my GT8800, only the device emulation device. So it looks like the CUDA kext does not load under SL.