Cuda 3.0 on Debian Lenny

I was looking for this topic in the forum but I did not found anything, so my apologies if it was solved before.

I’m trying to run Cuda 3.0 SDK examples on a Debian Lenny 64bits machine but a lot of the examples crash with various messages. I followed the instructions from the “Nvidia Installation and Verification on Linux” and deviceQuery and bandwidthTest passed the test. But a lot of examples (most of them uses the X11 environment) crash with different messages:

codex@alice:~/NVIDIA_GPU_Computing_SDK/C/bin/linux/release$ ./fluidsGL 

[fluidsGL] - [OpenGL/CUDA simulation]

CUDA device [GeForce 9800 GT] has 14 Multi-Processors : cutilCheckMsg() CUTIL CUDA error : cudaMalloc failed : unknown error.
codex@alice:~/NVIDIA_GPU_Computing_SDK/C/bin/linux/release$ ./smokeParticles 

[ CUDA Smoke Particles ]

Loaded './../../../src/smokeParticles/data/floortile.ppm', 256 x 256 pixels : cudaSafeCall() Runtime API error : unknown error.
codex@alice:~/NVIDIA_GPU_Computing_SDK/C/bin/linux/release$ ./nbody

Run "nbody -benchmark [-n=<numBodies>]" to measure perfomance.

	-fullscreen (run n-body simulation in fullscreen mode)

	-fp64	   (use double precision floating point values for simulation)

> Windowed mode

> Simulation data stored in video memory

> Single precision floating point simulation

> Compute 1.1 CUDA device: [GeForce 9800 GT]

bodysystemcuda_impl.h(135) : cudaSafeCall() Runtime API error : unknown error.

Then, looking in this forum, I followed the instructions from this thread (which are for cuda 2.3 + Lenny) but I’m still receiving these errors.

Does anyone knows how to run cuda 3.0 on Debian Lenny?

Thank you very much in advanced.

P.S.: I’m using the 195.36.15 Nvidia driver and everything is downloaded for 64 bits. I did export CC=“gcc-4.1” and I downloaded all the mesa, libgl, libglu, libxi, libglut libraries.

If you installed the mesa package after the nvidia drivers there’s a change that the nvidia GL libraries were overwritten by the mesa ones.
Try reinstalling the nvidia driver and type “glxinfo” and or “nvidia-settings” in a terminal to see if it has been installed correctly.


I’ve reinstalled the nvidia driver and I still have the same problem. Here is the output of glxinfo, so I think glx works correctly.

codex@alice:~$ glxinfo |grep NVIDIA

server glx vendor string: NVIDIA Corporation

client glx vendor string: NVIDIA Corporation

OpenGL vendor string: NVIDIA Corporation

OpenGL version string: 3.2.0 NVIDIA 195.36.15

It is quite confusing. If I downgrade to CUDA 2.30 toolkit and I use the 190.53 driver everything works fine. But it bothers me to have to use an old version instead of the last one.

By the way, I receive a lot of warnings in the SDK examples compilation related to cpp. In spite of the fact that they are not important (extra tokens, unused parameters, etc.) is it possible that the problem is the g++ compiler? Is there any recomended version like in the gcc compiler? I’ve tried to link g++ to g+±4.1 and g+±4.3, bit it didn’t work.

Anyway, thank you for your answer.


Personally, I’d recommend g+±4.3
Haven’t had any problems with the 4.3 compiler

Are you combining the right toolkit and SDK versions?
toolkit 3.0 <-> SDK 3.0
toolkit 2.3 <-> SDK 2.3