Cuda 3.2, GPUSurf and cudaErrorInvalidKernelImage


I’ve just started working with Cuda, and so i’ve just been looking through some sample code (which all works). I couldn’t get Cuda 4.0 working on my Macbook, which is running Windows 7 x64, so i’ve installed 3.2.

Now, i found a GPUSurf utility online and i’ve been trying to get that working. The problem i’m having is that i’m unable to allocate and memory on the GPU. Also, when i try calling cudaMemGetInfo(…,…) it returns me the error cudaErrorInvalidKernelImage.

I thought that it was the position of the calls that were causing these issues, so i placed cudaMemGetInfo at the beginning of some sample code in the Cuda SDK and in GPUSurf. It worked fine in the Cuda SDK but it still didn’t work in GPUSurf.

I’ve checked to make sure that everything is pointing to the right version of the library (i.e. the 3.2 version and uninstalled all of 4.0 stuff). I haven’t compiled my own version of cutil32D.lib, but maybe i should.

Much appreciated for any enlightening thoughts on what could be going wrong.

Ok, solved the issue. I was building a library but wasn’t using the new version so i did a copy and now it all works.