CUDA 5.5 : trying to debug

Hi guys

I have installed on my system CUDA 5.5 and recent drivers.

Running Fedora 18 x86_64

NVIDIA-Linux-x86_64-319.17.run :

[t]$ cat /proc/driver/nvidia/version
NVRM version: NVIDIA UNIX x86_64 Kernel Module 319.23 Thu May 16 19:36:02 PDT 2013
GCC version: gcc version 4.7.2 20121109 (Red Hat 4.7.2-8) (GCC)

cuda_5.5.22_linux_64.run

[t]$ nvcc --version
nvcc: NVIDIA ® Cuda compiler driver
Copyright © 2005-2013 NVIDIA Corporation
Built on Wed_Jul_17_18:36:13_PDT_2013
Cuda compilation tools, release 5.5, V5.5.0

I am using a dual GPU system (X running on the integrated Intel HD Graphics card, CUDA running on the Geforce). The purpose being : I want to be able to debug my CUDA code.
Therefore, I cannot use the driver provided by the cuda_5.5 installer - this messes up X and ruins everything. I have to install the driver manually.

The problem is : the particular driver above and the CUDA 5.5 versions are incompatible - cuda-gdb returns the following message :

Incompatible CUDA driver version. Expected 5.5.98 or later and found 5.5.95 instead.

Can someone redirect me to the proper drivers/CUDA package to download ? I can’t find anything.

Thanks

Best regards,

Patrick

319.17 is too early of a driver to use for CUDA 5.5. I would recommend using the CUDA 5.5 run file installer to handle this.

Run it with the --extract option:
./cuda_5.5.run --extract /place/that/exists

This will output three individual run file installers (toolkit, samples, driver) at /place/that/exists. Then you can use the driver run file installer just like you used the 319.17 installers.

Hi Andy,

Thank you for your help. Allinea DDT now works like a charm. :-)

Best regards,

Patrick