CUDA 6.5 Installation repo hash not secure

Hi i am trying to install cuda 6.5 in ubuntu 16.04

I downloaded the deb and after I try and run an update I get the following error

so I run a sudo apt-get update and get the following error
W: file:///var/cuda-repo-6-5-prod/Release.gpg: Signature by key 889BEE522DA690103C4B085ED88C3D385C37D3BE uses weak digest algorithm (SHA1)
E: Failed to fetch file:/var/cuda-repo-6-5-prod/Release No Hash entry in Release file /var/lib/apt/lists/partial/_var_cuda-repo-6-5-prod_Release which is considered strong enough for security

Does anyone know how to fix this? Do we need people from nividia to update the hash?

I have the following package installed
ii cuda-repo-ubuntu1404-6-5-prod 6.5-19 amd64 CUDA repo configuration files.

1 Like

Ubuntu 16.04 is not a supported OS for CUDA 6.5

Please read the linux installation guide for CUDA 6.5 for supported OS’s.

I just installed JetPack 2.3 on the Jetson TX1 and I’m getting the same error with CUDA 8.0.

W: file:///var/cuda-repo-8-0-local/Release.gpg: Signature by key 889BEE522DA690103C4B085ED88C3D385C37D3B3 uses weak digest algorithm (SHA01). I’ve got a feeling this is an issue on NVIDIA’s side.

1 Like

Maybe supporting your products a bit longer would make me want to buy another one. Given the experience with the TK1 all these are Development Kits are money thrown out of the window.