Cuda 6 on Fedora 19

I’m having trouble installing the CUDA 6.0 toolkit on Fedora 19.

Using the .run installer, I get:

“Error: unsupported compiler: 4.8.2. Use --override to override this check.”

Following this advice produces an unusable driver that won’t load X. Note that this is the latest gcc compiler in “production” repositories.

If I use the yum repository to install cuda-6-0, it does not seem to produce a kernel module. For example, “lsmod | grep nv” returns nothing.

FC19 is supported, but the expected (i.e. officially tested and supported) gcc version is 4.8.1:

http://docs.nvidia.com/cuda/cuda-getting-started-guide-for-linux/index.html#axzz30Z3oclDC

Perhaps at some point you updated your compiler from 4.8.1 to 4.8.2

If you revert to a vanilla install of FC19, it “should work”, i.e. that is what was tested.

Thank you for your response.

It isn’t feasible for me to downgrade gcc on my system (other packages require 4.8.2.) So, I am trying to install via the .rpm/yum repository. I’m stuck on getting the kernel module installed.

I see two packages: nvidia-kmod from the cuda repository and kmod-nvidia from the rpmfusion repository. Neither seems to work. I have installed the former but X complains that it can’t load the driver on startup. If I do an ‘lsmod | grep nv’, nothing shows up.

The nvidia-kmod package is 331.62 (from the cuda repo) whereas the xorg-x11-drv-nvidia package is 331.67 (from rpmfusion-nonfree-updates). Are these compatible? This is just what the repo gave me with the cuda-6-0 metapackage. What is the connection between these two packages and are both required?

I think I solved it. There were lingering xorg-x11-drv-nvidia-* packages from rpmfusion with a higher version number than what’s required by the cuda-6-0 metapackage. yum tries to get the most recent version of each required package and the ones it really needed were obsoleted by rpmfusion’s copies. Removing all the xorg-x11-drv-nvidia packages followed by disabling rpmfusion and reinstalling the cuda-6-0 metapackage fixed it.