CUDA 7.0 and 7.5 drivers do not work on Debian Wheezy KVM guest

Hit across a roadblock and any help would be much appreciated!

I have successfully managed to passthrough a GTX970 card to a KVM guest running Debian Jessie(3.16 Kernel), and am able to run CUDA 7.5 toolkit samples.
However the same does not work on Debian Wheezy guest(3.2 Kernel). nvidia-smi fails to probe guest GPU device with the following error in dmesg:

[   86.116320] nvidia 0000:00:06.0: irq 45 for MSI/MSI-X
[   86.335157] NVRM: RmInitAdapter failed! (0x24:0x1f:1244)
[   86.335162] NVRM: rm_init_adapter failed for device bearing minor number 0
[   86.335324] NVRM: nvidia_frontend_open: minor 0, module->open() failed, error -5

I have tried multiple versions of NVIDIA drivers on two different KVM guests, one running Wheezy and another running Jessie. Here’s what I have:

Host: Debian Jessie (3.16 Kernel). GTX970 passthrough using VFIO to KVM Guest

Driver Version     Debian Wheezy Guest        Debian Jessie Guest
361.28             Not Working                Working
352.79             Not Working                Working
352.63             Not Working                Working
346.96             Not Working                Working
343.22             Working                    Working

For the ‘Not working’ cases I get the exact same error as previously mentioned.
Although driver version 343.22 works on Debian Wheezy guest, unfortunately this will not work with CUDA 7.0 or 7.5

The installations are stock installations, no kernel patching has been done.

Is there anything I could tweak in Debian Wheezy KVM guest to get the latest drivers working?