CUDA 7.5 -> Clang is not supported?

Hi guys, I just installed the new CUDA 7.5 toolkit on OS X 10.10.4, and when I attempted to build the samples I get the following error:
nvcc fatal : The version (‘60100’) of the host compiler (‘Apple clang’) is not supported

I did previously have the Xcode 7 beta installed before going back to using Xcode 6.4, so maybe there’s a beta version of Clang that’s been installed? Any advice is appreciated!

I have the same problem

The version (‘60100’) of the host compiler (‘Apple clang’) is not supported

The CUDA_Installation_Guide_Mac.pdf indicates the officially supported versions in Table 1 “Mac Operating System Support in CUDA 7.5”

It looks to me like Xcode 6.1 and 6.2 are supported, both of which have apple LLVM 6.0 in them.

I downloaded XCode 6.2 to replace 6.3
http://christopher5106.github.io/big/data/2015/07/16/deep-learning-install-caffe-cudnn-cuda-for-digits-python-on-mac-osx.html