Cuda 7.5 Lubuntu 15.04 GeForce GT 630 can't start system anymore (only recovery mode)

Hi, I downloaded cuda 7.5 release candidate from nvidia’s page, after installing I can’t start graphic mode anymore. Using the rescue mode I tried:
My architecture is x86_64, gcc 4.9.2, Intel Core i7-3770 3.40 GHz, Linux kernel 3.19.0-26-generic

apt-get remove --purge nvidia

After executing this as root nvidia directories where still there but no unninstal binary.

sudo apt-get autoremove

as a normal user I manager to start the system in text only mode.

Then I tried installing the release version of 7.5 but now I only get a message of

Starting version 219

Again only the rescue mode works.

As I installed I remember a message suggesting to change something in grub to load a different kernel in case the drive didn’t load, however, since I was using the text mode I couldn’t go back to see what it said. In grub in “advanced options” I can see options to load previous versions of the kernel, but any of them works, I assume they are all using the new driver now.

So, how do I go to a working version or even better… is there a way to make cuda 7.5 and everything else work with this system?

Thanks a lot in advance