Cuda 7 is bricking my Dell Precision M3800 under multiple Linux distros.

I am trying to run the new Cuda 7 on the Dell Precision M3800 (2014 version - 2015 they have announced a very minor upgrade with a slightly higher dpi retina display. Mine came with Windows), but I want to do so under Linux.

Exasperated as all permuations of installs brick the computer, except for running lightweight (non-accelerated) display managers such as i3 or LXDE.

I have tried the installation several times, using .deb on 14.04 and 14.10 Ubuntu fresh installations, also .rpm on OpenSUSE 13.2 fresh install using all of the instructions: http://docs.nvidia.com/cuda/cuda-getting-started-guide-for-linux/index.html#axzz3VhcfbR3Y

In all cases Cuda works fine (testing using Anaconda Accelerate) until I reboot, and then it bricks even before the login screen.

I think it’s happening at the ACPI daemon because that’s where it freezes if I boot to text mode.

I have been able to get the .run file working on Ubuntu, but only under lightweight window managers (i3 and LXDE). The .run installation seems not to brick the login screen, but I get errors if I am running any accelerated window manager such as Unity, or Gnome 3.

So I can get Linux + Cuda 7 on this M3800, but then I don’t have accelerated graphics (literally 1 fps if I use enlightenment software rendering on the webgl cubes).

Any clues?

It’s strange because it seems to work fine if I don’t reboot. Until I do so, I have Cuda 7 and accelerated graphics, under Unity (or gnome).

Yes I did blacklist Nouveau, and under i3/.run if I run the Ubuntu drivers page it shows up as manual driver being used. If i use .deb/.rpm then before reboot It shows Nouveau selected still (though i believe this is normal as Cuda 7 wraps 346 driver under Nouveau or something?). After reboot, brick.

Anyway highly frustrated. Would happily tear out the Intel HD4600 chip which I am sure is the source of all the complication in this laptop, and use Nvidia only as I care much more for performance than batteries.

sounds similar to my issue, but sounds like you’ve been around linux longer than me, so I’m not sure I can add anything that will help, but here is what I’ve found. First, I have a Gigabyte ga-z77x-up5 th mb running Ubuntu 14.10. With a fresh Ubuntu install and a GTX 970 installed, I go thru all the Nvidia getting started (disable Nouveau for instance), and all appears to work (I’m not a gamer so can’t verify all of that, but my single monitor is plugged into the GTX and desktop, mouse and keyboard all work.)

Then I download CUDA and start compiling samples, and they all work except those that require OpenGL. I can’t compile any of those. But the others work, so my GPU is working. Then I start trying to fix the OpenGL samples. Following advice on Ubuntu forums, I apt-get install the various libraries that contain libGLU, libX11, libXmu and whatever else the linker complains is missing. Everything still works at that point, but the linker is still not happy because it can’t find the libraries because they are in a different place than the make file is looking. So I fix that by modifying the make file to look where Ubuntu put things and finally get to where I can build the graphic samples, but then when I run the executable I get run time errors, it can’t find the libraries. So I think, well, guess I need to reboot to get those libraries loaded, and just like you, I end up with a bricked box. I don’t know where it stops, you mentioned the ACPI daemon but I don’t know how to tell. All I know is I have a black screen and the boot codes on the mb stop changing. I can’t remote login to the box so there is no way to uninstall those libraries at that point, I have to do a fresh Ubuntu install and start over. Don’t know if that tells you anything extra. If you find a solution, please update the thread.

well, got my issue solved. this was tedious to say the least,but what I did was

  1. fresh 14.10 ubuntu install
  2. installed nvidia drivers using the .deb file. I prefer the .run method, but tried the .deb file to see if that got me any further. It didn’t seem to but I’m new enough at this that undoing the .deb versions just to reinstall with .run doesn’t seem worth the effort. Maybe there’s a reason to, but I don’t know it yet.
  3. re-read the Getting Started manual, in particular hunting down and verifying locations of all the .so files. I found them all but not in the locations it mentions, so then I had to modify the make files…

I’ve rearranged the order of the rest of this to cut out some trial an error, here’s the order I think would work for anyone else going thru this.

  1. created symbolic links in the usr/lib directory for the libraries reported missing by findgllib. That file specifies things like libGL.so but what is actually installed is something like libGL.so.1 so I created a link using LINK libGL.so.1 libGL.so. I did this for the other 4 or so missing libraries too.
  2. modified the findgllib file to fix the include file paths for the missing gl.h, glu.h. I did this by changing the HEADER_SEARCH_PATH line to HEADER_SEARCH_PATH ?= /usr/local/cuda-7.0/extras/CUPTI/include/GL.
  3. updated Makefile INCLUDES value with INCLUDES += -I/usr/local/cuda-7.0/extras/CUPTI/include
  4. updated Makefile LIBRARIES value with LIBRARIES += -L/usr/lib/x86_64-linux-gnu.

At this point I was able to compile and link, but was now getting some missing symbols errors from the linker due to a missing glut library. This is where I had to install a new library using
sudo apt-get install freeglut3 freeglut3-dev

Now I rebooted and the first time it bricked, I think because I unplugged my keyboard. Then I rebooted again without unplugging the keyboard and the system came up. I ran the make file and the Mandelbrot program was built correctly and then I was able to run it and test all its functionality successfully.

This is the first time I have seen GPU graphics running inside my desktop, very cool!!

vegabook, I’m sorry if none of this helps you and I kinda took over your thread. The most important thing I think I did was avoid installing new libraries suggested by the Ubuntu crowd until I had no other choice. But even with that, when I installed freeglut3, it installed a ton of other dependencies so it’s hard for me to be sure what really got installed. Bottom line is I have Cuda 7 and Ubuntu 14.10 running together.

In case you or anyone still having this issue, might want to try following the instructions in this link:

After many fragile installations and wasted time/effort, the above finally solved my issues. Basically the issue seems to be Unity and Gnome. Install Ubuntu Server and then KDE.

Good luck.

EDIT: this install is much more stable than your solution above, in my opinion. Furthermore, if you’re interested in the rest of the deep learning stack, eg theano, pycuda, etc… you might want to follow the following link from somewhere in the middle after you’ve followed the install instructions in the link above:

This worked. Hallelujah! Finally have CUDA, multiscreen hidpi, reliable and stable under this KDE / Ubuntu Server setup on my Dell M3800. Goodbye Unity! Goodbye Gnome. Hello KDE.